WordPress.org

Forums

  1. toddheitner
    Member
    Posted 1 year ago #

    I've been trying to track down something strange that's started happening on my site and this plugin was one of the last I'd suspect of being the culprit, but it turns out it is. I'm hoping you can help me resolve this because this plugin is great and a critical part.

    For some reason if any page on my site is loaded in a frame (such as domain forwarding with masking), the page breaks out of the frame and redirects in the user's address bar. I have clients that sometimes want to point a separate domain to their property listings but not have it be linked to the rest of their site. Because of this redirect, that's no longer possible.

    I don't see any option for disabling this, and I don't see any reason why it would be happening.

    https://wordpress.org/plugins/wp-property/

  2. toddheitner
    Member
    Posted 1 year ago #

    I found in the code something that seems to be related to this issue. At the top of every page on the site, it has a section that begins with:
    /* <![CDATA[ */

    And one of the items is:
    iframe_enabled":false

    So apparently this is a built-in feature but I don't see any way to disable it.

  3. MariaKravchenko
    Usability Dynamics Support
    Plugin Contributor

    Posted 1 year ago #

    Hello,toddheitner

    You can use filter 'wpp::get_instance' to set iframe_enabled = true
    For more details, see WPP_Core::get_instance() method in core/class_core.php

    Regards.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.