Support » Plugin: W3 Total Cache » Strange random error: Cannot use output buffering in output buffering display ha

  • I’m a bit helpless right now. I’m experiencing some rather strange errors on my wordpress site with W3 Total Cache. I can’t tell if they startet with installing this plugin or after that. I tried searching google for a couple of times but I can’t find any proper solution. I also am not able to reprodruce this error at will. It seems to appear randomly a couple of times per day. I checked the requests URL and they were all totally different. I basically happens on all pages of my blog. Heres the error including the stacktrace:

    mod_fcgid: stderr: PHP Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0
    mod_fcgid: stderr: PHP Stack trace:
    mod_fcgid: stderr: PHP 1. shutdown_action_hook() /var/www/mydomain.com/htdocs/subdomain/wp-includes/load.php:0
    mod_fcgid: stderr: PHP 2. do_action() /var/www/mydomain.com/htdocs/subdomain/wp-includes/load.php:580
    mod_fcgid: stderr: PHP 3. call_user_func_array() /var/www/mydomain.com/htdocs/subdomain/wp-includes/plugin.php:429
    mod_fcgid: stderr: PHP 4. wp_ob_end_flush_all() /var/www/mydomain.com/htdocs/subdomain/wp-includes/plugin.php:429
    mod_fcgid: stderr: PHP 5. ob_end_flush() /var/www/mydomain.com/htdocs/subdomain/wp-includes/functions.php:2773
    mod_fcgid: stderr: PHP 6. W3_Plugin_TotalCache->ob_callback() /var/www/mydomain.com/htdocs/subdomain/wp-includes/functions.php:2773
    mod_fcgid: stderr: PHP 7. w3tc_do_ob_callbacks() /var/www/mydomain.com/htdocs/subdomain/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCache.php:668
    mod_fcgid: stderr: PHP 8. call_user_func() /var/www/mydomain.com/htdocs/subdomain/wp-content/plugins/w3-total-cache/inc/functions/plugin.php:23
    mod_fcgid: stderr: PHP 9. W3_PgCache->ob_callback() /var/www/mydomain.com/htdocs/subdomain/wp-content/plugins/w3-total-cache/inc/functions/plugin.php:23
    mod_fcgid: stderr: PHP 10. W3_PgCache->_can_cache_buffer() /var/www/mydomain.com/htdocs/subdomain/wp-content/plugins/w3-total-cache/lib/W3/PgCache.php:338
    mod_fcgid: stderr: PHP 11. W3_PgCache->_send_headers() /var/www/mydomain.com/htdocs/subdomain/wp-content/plugins/w3-total-cache/lib/W3/PgCache.php:1543

    And here is a list of all plugins I have currently installed. Since I’m not able to reprodruce this error I have not tried to turn of all plugins individually. I see no point in doing so without having a single glue whats happening there.

    all-in-one-favicon
    contact-form-7
    footer-text
    google-sitemap-generator
    jetpack
    w3-total-cache
    wp-mail-smtp
    wp-maintenance-mode
    wp-piwik
    wp-recaptcha
    wpseo

    I’m using the respectively current version of each plugin. I hope this is helpfull. Otherwise I will provide a list that includes each version.

    I would really appreciate if someone could at least give me a hint what could possible be the source of this error.

    http://wordpress.org/plugins/w3-total-cache/

  • The topic ‘Strange random error: Cannot use output buffering in output buffering display ha’ is closed to new replies.