Support » Fixing WordPress » Strange problem with Flash image uploader

  • My site’s been up for about a year now and I haven’t had any troubles until this morning. I was trying to upload an image to a post the same way I always do through the image uploader, but once the upload bar filled to 100%, the login/password box popped up within the image uploader window. I put in my login and password, but it said “try again” and the same thing happens every time.

    The only change I’ve made to my site is registering a new user as an editor, but I’m registered as an Admin and the problem took place before he even knew he had editor access.

    Anybody know what could be causing this?

    Thanks in advance.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.


    In addition to esmi’s reply, also check with upgrading your wordpress blog to the latest version and resetting 755 recursive permissions to wp-content folder.


    Shane G.

    Thanks so much for the suggestions and quick responses!

    Tried all the above advice and I’m already running the latest version, but I’m not sure what that 755 recursive permissions stuff means. Sorry.

    Any help would be great. This site is sort of my livelihood at the moment and I really hope to find a way to fix this, but I don’t have much technical knowledge when it comes to these things.

    Thanks again.

    Thanks. I’ll try that.

    Just so it never happens again, any clue what could have caused this strange error? Could it really have been caused just by adding a new editor to the site? Or was it probably something else?

    Adding a new user shouldn’t cause this kind of problem. It may have been due to an (accidental?) change on the site’s server that had nothing to do with you. Can you post a link to the site?


    Here’s the link:

    Thanks again. I really appreciate all this help.

    Nothing obviously amiss on the site. I wanted to check it out as, sometimes, issues in the Admin area can be an early sign of a hacked site but I can’t see any evidence of that on your site.

    I’d suggest keeping an eye on the site for a little while and see if anything like this happens again. If it does, try contacting your hosts. They may be running maintenance or upgrading the server. Occasionally, something can go slightly wrong or gets missed.

    Just got off the phone with my web host and they said the permissions looked fine, but they couldn’t locate the error. They even tracked the error log live while I tried uploading an image and couldn’t see anything.

    So weird. As soon as the image upload gets to 100% and says “crunching” the wordpress login screen pops up inside the little image uploading box.

    Even weirder still is the fact that the new author that I added has no trouble uploading images at all.

    The browser uploader works fine, but I have a few image-heavy posts that I need to go up and uploading one by on is a bit of a pain, but I guess I can manage although I’d really like to sort the problem out.

    Is this happening with specific images or all images? Have you changed your graphics editor recently? Or the source of your images?

    Did you try the plugin deactivation test? Or resetting the plugin folder?

    Tried deactivating all plugins and resetting the plugin folder. Happens with all images. Tried re-uploading a fresh swfupload folder in the /wp-includes/js/ directory, but it didn’t work either.

    Can you try switching to the default theme temporarily to see if that helps at all?

    Switched to the default theme and the problem persists. A new problem I just noticed is that the upload images button is gone from the Flash uploader completely now since this morning.

    Have you tried re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress? (I’m losing track of what’s been tried already).

    Just tried reuploading fresh wp-includes and wp-admin folders, but it just made it worse. Whenever I’d try to make a new post or edit a draft all of the buttons looked like a bunch of scribbled pixels, so I just went back to the old wp-admin and wp-includes folders.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Strange problem with Flash image uploader’ is closed to new replies.