WordPress.org

Support

Support » Plugins and Hacks » HungryFEED » strange problem with cut off url encoded feed

strange problem with cut off url encoded feed

  • Hi all,

    I can’t get rid of a url encoded character in my feed. Somehow the &hellip character is cut off to &helli which causes Hungryfeed to print it as text and not as the three dots (…) that the character stands for. If you look at the original wordpress feed (http://www.numuseum.nl/blog/feed/) it look perfectly normal, has been validated and displays well in my browser (FireFox). However when you look at the Hungryfeed result (http://awarenesslab.nl/achtergrond/nieuws/, please scroll down to blog section) you see the results displayed like this:
    xbee hello world!
    Today I’ve had my first success with communicating between two Xbees. Mostly thanks to this simple but clear tutorial. After installing the XCTU software with Thijs a few months back I had forgotten quite a lot of his private class &helli
    etc.

    I’m not sure if the problem lies with the feed or with the Hungryfeed plugin. I use version 1.6.1.
    Any help would be greatly appreciated, TIA, danielle

    http://wordpress.org/extend/plugins/hungryfeed/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jason

    @verysimple

    The problem could be with SimplePie – which is the component that comes with WordPress used by HungryFEED to actually process the feed. It sometimes chokes a little bit on feeds that have different charsets.

    One thing that you can try is to use a feed aggregator like yahoo pipes as a “middle man” between your feed and HungryFEED. I have seen several people have good luck with that technique. Yahoo pipes can transform or clean out your feed so that HungryFEED can deal with it – sometimes it even just fixes charset issues without you having to do anything.

    Hi Jason,

    Thanks for your reply. I’ve tried the yahoo pipes (great stuff by the way) and it works nicely for one feed (the facebook feed also had special characters in it.) But I’m afraid the WordPress feed from my blog still is looking the same. This is the pipe URL: http://pipes.yahoo.com/pipes/pipe.info?_id=4287ed761be125a6238494438473e4e4
    When I get it as RSS it all looks fine but when I use the RSS together with hungryfeed on my website I get the same problem: &helli cut off.

    Any suggestions are very welcome, best, d.

    Plugin Author Jason

    @verysimple

    I’m getting this, it seems to look ok to me – is this how it’s supposed to look…?

    View post on imgur.com

    Yes, Jason, that’s how it should look.
    Could you please post the shortcode for that result? Thanks, danielle.

    Plugin Author Jason

    @verysimple

    sure it’s this…

    [hungryfeed url="http://pipes.yahoo.com/pipes/pipe.run?_id=4287ed761be125a6238494438473e4e4&_render=rss"]

    Thanks Jason, works great now: http://awarenesslab.nl/achtergrond/nieuws/
    Except for the single quote in the Facebook feed title: I've ordered my etc. Strangely enough it is displayed OK as text, view below the title. Any ideas on that? Thanks very much for you help, best, d

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘strange problem with cut off url encoded feed’ is closed to new replies.
Skip to toolbar