Support » Fixing WordPress » Strange Problem – Saving Options in WP-Admin – Only Fixed By PHP-FPM Restart

  • Hello!

    Here are the variables:

    – WordPress 3.6 – 2 fairly identical installations on different
    domains on the same server
    – Nginx (same config files)
    – PHP5-FPM
    – APC
    – Varnish 3

    Here’s the problem:

    – On only ONE WordPress installation (remember they are pretty much
    identical, same theme, etc.) sometimes the settings do not save in the
    wp-admin section under “general” or with plugins, etc. Posts seem to
    save, but settings sometimes don’t. And I have managed to solve what
    WILL update them. Basically, if I do a sudo service php5-fpm restart
    they IMMEDIATELY are updated w/ what changes I made before. So it’s
    like the changes are stuck in some sort of cache. HOWEVER:

    – Only 1 installation of WP ever does this, both have same plugins,
    same server, same version, etc. Other one NEVER has this happen.
    Emptying APC opcache did NOT help. Emptying Varnish cache with sudo
    varnishadm “ban.url .” did not help. Only doing a service php5-fpm
    restart immediately corrects the situation.

    Now my question of course would be how could this happen on only 1 of
    the wordpress installs/domains.. but, the more important question is
    why the heck would I have to restart php5-fpm to “unstick” the updates
    I’m making in admin panel.

    Any thoughts? Thank you so much!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Since, it resolves when php5-fpm is restarted, try using separate processes for each site. This involves several steps. Let me provide an overview of the steps involved…

    – Currently, if you are in Ubuntu / Debian, you may have a file, such as, /etc/php5/fpm/pool.d/www.conf .

    – You may take a copy of this file…

    cd /etc/php5/fpm/pool.d/; cp www.conf www1.conf

    – Then you may change the pool name (“www”), and the listen directive. For example, if it has listen =, you may change this to listen = Or if it has listen = /var/lock/php-fpm, you may change this to listen = /var/lock/php-fpm-v2

    – Then you may change the nginx configuration accordingly for the site inwhich the weird things are happening. For example, you may change the value of “fastcgipass”, depending on what is set in the above step.

    Hopefully, it resolves the issue. I still wonder why php5-fpm process needs to be restarted to solve it.

    Update: Please try adding another site, a test site, into this stack and see what happens in it. The test site doesn’t need to be the exact replication of the other sites. Just a bare-bone site should do.

    Hi Pothi,

    Thank you very much for the response.

    I was wondering, do you know why separate processes might solve this issue?

    Or will it just transfer the issue to half of the php5-fpm processes used? (the ones associated w/ the site doing the problem)

    I suspect a test site would not have a problem, as 1 of them does not. But, it’s a good idea. Thank you.

    Here’s what was going on:

    1 wordpress install had the APC plugin in wp-content and one did not.. LOL

    Thank you for sharing what was behind the issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Strange Problem – Saving Options in WP-Admin – Only Fixed By PHP-FPM Restart’ is closed to new replies.