Support » Plugin: EWWW Image Optimizer » Strange message after installing plugin

  • Resolved mikesantamar

    (@mikesantamar)


    After installing the plugin EWWW Image Optimizer, I see this message:

    EWWW Image Optimizer requires exec() or an API key. Your system administrator has disabled the exec() function, ask them to enable it.

    However, below there is another message:
    Plugin Status All Clear

    I want to run the Bulk Optimize but I am not sure if it will cause a disaster. May I safely run it?
    Thanks
    Miguel

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Please turn on the debugging option, and post the debug information via pastebin.com

    Hi
    pastebin.com has returned this “RAW Paste Data”:

    trekpyre
    EWWW IO version: 326.0
    WP version: 4.7.2
    PHP version: 50445
    libxml version: 20901
    ewww_image_optimizer_gallery_support()
    ewww_image_optimizer_admin_init()
    ewww_image_optimizer_cloud_init()
    ewww_image_optimizer_upgrade()
    ewww_image_optimizer_exec_init()
    ewww_image_optimizer_cron_setup()
    ewww_image_optimizer_tool_init()
    ewww_image_optimizer_install_tools()
    Checking/Installing tools in /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/
    wp-content/ewww permissions: 0755
    ewww_image_optimizer_install_paths()
    CPU architecture: x86_64
    generated paths:
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/plugins/ewww-image-optimizer/binaries/jpegtran-linux
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/plugins/ewww-image-optimizer/binaries/optipng-linux
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/plugins/ewww-image-optimizer/binaries/gifsicle-linux
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/plugins/ewww-image-optimizer/binaries/pngquant-linux
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/plugins/ewww-image-optimizer/binaries/cwebp-linux
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/jpegtran
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/optipng
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/gifsicle
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/pngquant
    /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/cwebp
    ewww_image_optimizer_skip_tools()
    enabled: jpegtran
    enabled: optipng
    enabled: gifsicle
    Linux/UNIX style OS, checking permissions
    ewww_image_optimizer_check_permissions()
    permissions for /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/jpegtran: 0755
    permissions ok
    ewww_image_optimizer_check_permissions()
    permissions for /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/gifsicle: 0755
    permissions ok
    ewww_image_optimizer_check_permissions()
    permissions for /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content/ewww/optipng: 0755
    permissions ok
    ewww_image_optimizer_settings_script()
    ewww_image_optimizer_bulk_script()
    ewww_image_optimizer_webp_script()
    ewww_image_optimizer_notice_utils()
    ewww_image_optimizer_exec_check()
    disable_functions: dl,exec,passthru,pfsockopen,posix_kill,posix_mkfifo,posix_setuid,proc_close,proc_open,proc_terminate,shell_exec,system,leak,posix_setpgid,posix_setsid,proc_get_status,proc_nice,show_source,popen,escapeshellcmd
    suhosin_blacklist:
    exec seems to be disabled
    ewww_image_optimizer_disable_tools()
    ewww_image_optimizer_options()
    ABSPATH: /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/
    WP_CONTENT_DIR: /var/www/vhosts/trekpyrenees.com/landing.trekpyrenees.com/wp-content
    home url: http://www.trekpyrenees.com/en
    site url: http://www.trekpyrenees.com
    ewww_image_optimizer_savings()
    querying savings for single site
    query to be performed: SELECT SUM(orig_size-image_size) FROM wp_ewwwio_images
    savings found: 2120959
    240 images have been optimized
    ewww_image_optimizer_skip_tools()
    enabled: jpegtran
    enabled: optipng
    enabled: gifsicle
    remove metadata: on
    jpg level: 10
    png level: 10
    gif level: 10
    pdf level: 0
    bulk delay: 0
    optipng level: 2
    pngout disabled: yes
    pngout level: 2
    ewww_image_optimizer_jpg_quality()
    quality: 100
    parallel optimization: off
    background optimization: on
    scheduled optimization: off
    include media library: off
    max media dimensions: 0 x 0
    max other dimensions: 0 x 0
    resize existing images: off
    ewww_image_optimizer_get_image_sizes()
    Array ( [0] => thumbnail [1] => medium [2] => medium_large [3] => large [4] => optimize_mikado_square [5] => optimize_mikado_landscape [6] => optimize_mikado_portrait [7] => optimize_mikado_large_width [8] => optimize_mikado_large_height [9] => optimize_mikado_large_width_height )
    Array ( [thumbnail] => Array ( [width] => 150 [height] => 150 ) [medium] => Array ( [width] => 300 [height] => 300 ) [medium_large] => Array ( [width] => 768 [height] => 9999 ) [large] => Array ( [width] => 1024 [height] => 1024 ) [optimize_mikado_square] => Array ( [width] => 550 [height] => 550 ) [optimize_mikado_landscape] => Array ( [width] => 800 [height] => 600 ) [optimize_mikado_portrait] => Array ( [width] => 600 [height] => 800 ) [optimize_mikado_large_width] => Array ( [width] => 1000 [height] => 500 ) [optimize_mikado_large_height] => Array ( [width] => 500 [height] => 1000 ) [optimize_mikado_large_width_height] => Array ( [width] => 1000 [height] => 1000 ) [pdf-full] => Array ( [width] => 99999 [height] => 99999 ) )
    disabled resizes:
    thumbnail: optimization=enabled creation=enabled
    medium: optimization=enabled creation=enabled
    medium_large: optimization=enabled creation=enabled
    large: optimization=enabled creation=enabled
    optimize_mikado_square: optimization=enabled creation=enabled
    optimize_mikado_landscape: optimization=enabled creation=enabled
    optimize_mikado_portrait: optimization=enabled creation=enabled
    optimize_mikado_large_width: optimization=enabled creation=enabled
    optimize_mikado_large_height: optimization=enabled creation=enabled
    optimize_mikado_large_width_height: optimization=enabled creation=enabled
    pdf-full: optimization=enabled creation=enabled
    skip images smaller than: 0 bytes
    skip PNG images larger than: 0 bytes
    exclude originals from lossy: off
    exclude originals from metadata removal: off
    use system binaries: no
    delete originals: off
    jpg2png: off
    ewww_image_optimizer_jpg_background()
    ewww_image_optimizer_jpg_background()
    png2jpg: off
    gif2png: off
    webp conversion: off
    forced webp: off
    alt webp rewriting: off
    max_execution_time: 18000
    ewww_image_optimizer_stl_check()
    ewww_image_optimizer_safemode_check()
    safe_mode =
    disable_functions = dl,exec,passthru,pfsockopen,posix_kill,posix_mkfifo,posix_setuid,proc_close,proc_open,proc_terminate,shell_exec,system,leak,posix_setpgid,posix_setsid,proc_get_status,proc_nice,show_source,popen,escapeshellcmd
    ewww_image_optimizer_function_exists()
    disable_functions: dl,exec,passthru,pfsockopen,posix_kill,posix_mkfifo,posix_setuid,proc_close,proc_open,proc_terminate,shell_exec,system,leak,posix_setpgid,posix_setsid,proc_get_status,proc_nice,show_source,popen,escapeshellcmd
    detected memory limit is: 268435456

    Plugin Author nosilver4u

    (@nosilver4u)

    The idea was for you to post the link the the pastebin, but that works 🙂
    exec() is plainly disabled, so the warning is correct, you need to see if you can get that enabled by your webhost, or use the API: https://ewww.io/plans/

    I’ll have to double-check why the status area gives an all clear on that though, as it should say “Needs Attention” or something to that effect.

    First off I’m confirming that on a site I’m working on now, although exec() is disabled the status area gives ‘All Clear’.

    Now, one question if I may. I see the issue with disabled php functions is much common in shared hostings. Couldn’t ini_set() be used for the use of the certain plugin to avoid these problems?

    Most hosting providers won’t enable the exec() function.

    Plugin Author nosilver4u

    (@nosilver4u)

    Thanks for that confirmation, haven’t had a chance to dig into the “why” yet. At any rate, the disabled functions is a setting that cannot be overridden. Once it is set, that’s it.

    And I wouldn’t say most, because the list of known working providers is much larger than the list of non-working providers. And, (roughly) 99% of all EWWW users are not using the API.

    Regardless, the folks who have exec() disabled by their webhosts are exactly why I created the API. That way they can still use EWWW, and avoid any restrictions a webhost might have in place.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Strange message after installing plugin’ is closed to new replies.