Support » Fixing WordPress » Strange issue with wp-admin sidebar

  • Resolved BestBackwards

    (@bestbackwards)


    Since the upgrade to WordPress 4.1 (with the issue persisting on WP 4.3) all of our site admins have noticed an issue with the left-hand side bar on the wp-admin page.

    As some very basic troubleshooting steps, we’ve done the following:
    – Disabled all of the plugins
    – Done the above WITH having the site’s theme set as Twenty Fifteen.
    – Within the client’s browser, use an extension-less browsing session (both in Chrome and IE)

    … However the same issue is still there. Please take a look at the screenshot here . It is very difficult for me to explain how top reproduce this as it is very hit and miss. However, just by switching through different admin menus, some of the menu items just disappear. Really odd. If I refresh the page, they return, sometimes another might disappear.

    This is running on IIS 8.5 with PHP 5.4.

    Thanks,
    Josh

Viewing 15 replies - 1 through 15 (of 28 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    This is not a WordPress problem.

    Chrome 45, just released via automatic update yesterday, has a rendering bug.

    – Go to chrome://flags/#disable-slimming-paint
    – Enable the “Disable slimming paint” option.
    – Ensure that the “Enable slimming paint” option below it is not turned on.
    – Relaunch Chrome.

    I have the same issue, but I don’t understand the Samuel’s solution.

    I can confirm this issue. Samuel’s solution seems to work.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @rbnz: What part do you not understand?

    @samuel now I have understand but I’m worried to change that settings.
    The thing is that one my friend tell me that he haven’t that problem but I have this problem on all of my websites.
    I have the same Chrome version but I don’t understand why this issue is not for all the wordpress users that use chrome.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @rbnz: Currently, this is an actual issue for all users who use Chrome. However the nature of the bug is that it is a bit random. Sometimes it appears to mess up the layout of the menu, sometimes it does not. And taking certain actions which cause the menu to be “redrawn” by the browser on the page will seemingly “fix” the menu. Scrolling, for example, fixes it immediately on my laptop. Collapsing then expanding the menu fixes it as well. These fixes are temporary.

    The cause is a bug in “Slimming Paint”, which is the name for a new, well, call it “engine” added to Chrome. Basically it is a complex thing dealing with how Chrome handles layers. This bug was introduced and apparently not noticed by the Chrome team for a couple months, and then got accidentally released to the Stable version of Chrome. You got it when Chrome auto-updated, like it does every couple of weeks. Your friend might not have updated to Chrome 45 yet, or restarted his browser recently. When he does, he’ll have the issue too.

    Disabling Slimming Paint in the settings will simply make Chrome use the old rendering methods, fixing the issue for now. Eventually, Chrome will fix whatever bug is causing the problem, and you’ll receive that auto-update. By the time they make Slimming Paint permanent and remove the setting, the bug will be fixed. So, there’s no harm in disabling it. It’s a relatively minor thing in the long run.

    @samuel, the friend that I’d tell you before has the same version of Chrome and no problem..
    Anyway, if I Disable slimming paint I compromise something else in the Chrome functionality?
    With the new upgrade I have to reset that? Before or after the upgrade? How can I know when I have to reset that settings before Chrome update to a new version if the update is automatic?
    Thak you very much.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Anyway, if I Disable slimming paint I compromise something else in the Chrome functionality?

    No, nothing whatsoever is compromised. It’s just turning off a piece that should not have been turned on so soon. Not until they worked the bugs out.

    With the new upgrade I have to reset that?

    No, you will never have to change this setting again, ever. Chrome will handle it for you in future updates.

    @samuel, that my friend have tryed to login in my website from his Chrome and, with my website there is the issue, with his website the issue there isn’t.. So is an incompatibility just with some wordpress website and Chrome.
    Thank you for the help.

    Ok @samuel, my friend have that issue, He did’t see it because he have a lot of staff in the sidebar, so the problem wasn’t appeared.
    Thank you very much for the solution that is working!!

    Thanks Samuel Wood! You just saved me from going crazy. Thought it was from WordPress.

    Thank you Samuel Wood.
    Your solution resolved my issues with flickering and overlaping menu items in Chrome.

    Thread Starter BestBackwards

    (@bestbackwards)

    +1 to Samuel Wood (Otto)

    Have tried this on a couple of machines and resolved the issue from Chrome. Though this is not a WordPress bug, I am yet to see this issue affect any other websites. (Strange!).

    Thanks for the support, now to see if I can set this through Group Policy for the office.

    Hi, just tried the solution above (Disabling the “Slimming” option in Chrome) and there’s still an issue with the sidebar. It looks better but duplicates stuff when you hover over the tabs. See screenshot here http://highmarkdesigns.com/4-3-dashsboard-sidebar/

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @hannab: you did not perform the fix correctly. Examine this image and compare it to your settings.

    Cloudup qhfjldalkv4

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Strange issue with wp-admin sidebar’ is closed to new replies.