WordPress.org

Forums

NextGEN Gallery
Strange gaps showing in image list on gallery page (8 posts)

  1. HannahHill
    Member
    Posted 3 years ago #

    For some reason, strange gaps are showing on some of the gallery pages. Disabling plugins didn't help, everything looks good from the back end. Can't figure out what's going on.

    It's happening on pages 2-4. Here's page two: http://www.lanciaesmith.com/gallery/favourites-from-oxbridge-2011/?nggpage=2

    Any help would be appreciated! Thanks so much!

    Hannah

  2. HannahHill
    Member
    Posted 3 years ago #

    Guys....any idea what's up with this? I'd sure appreciate some help!

  3. mplsdigital
    Member
    Posted 3 years ago #

    I've had this issue too. I'm not sure what the cause is. But I seem to be able to get rid of the gaps if I go into Gallery > Manage Gallery > (click on the gallery you want to change) > Sort Gallery. Once you're in the sort gallery area, you can drag and drop them into new locations. For what ever reason (no logic that I can make out) just rearranging the images can shift the gaps around. And if you happen to land on an arrangement that the plugin arbitrarily deems worthy. For no reason at all, all of the sudden it works and the gaps disappear. Clearly that's not a real fix. But I figured I'd share anyway.

  4. mplsdigital
    Member
    Posted 3 years ago #

    Another thing that seems to help is Gallery > Options > Gallery Tab > Under sort options click Sort Thumbnails by Image ID. I'm starting to think it has something to do with the names of the files.

  5. mplsdigital
    Member
    Posted 3 years ago #

    False alarm. Thought I had them working. But I fixed one to break another. So I still can't get them all to work right either.

  6. HannahHill
    Member
    Posted 3 years ago #

    Thanks to a tip from a coworker, I think it's fixed! I went into the plugin stylesheet and found the .ngg-gallery-thumbnail element. Then I changed the 5px margin-right to a 0. Seems to have fixed it. Hope it works for you!

    Thanks for helping me try to figure this one out! I really appreciate it. :-)

  7. arretonshepley
    Member
    Posted 3 years ago #

    Hi
    Could you explain how I find the plug in style sheet and then the .ngg-gallery-thumbnail element please - as I am having this same problem.

    Many thanks

  8. HannahHill
    Member
    Posted 3 years ago #

    You will need to log in via FTP to find it. It will be in wp-content/plugins/nextgen-gallery/css/nggallery.css. Do a search in the stylesheet file (I use keyboard shortcut ctrl + F) for .ngg-gallery-thumbnail.

    I also had to change the .ngg-gallery-thumbnail-box element to read as shown below before the fix was complete.

    .ngg-gallery-thumbnail-box { float: none; display: inline-block; }

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.