Support » Fixing WordPress » Strange error after upgrading to v2.6

  • Hi

    I just upgraded to WP v2.6. I undeleted a bunch of themes that I wasn’t using, just leaving my present theme. I then uploaded a new theme that I want to try out but in WP on the Design->Themes Page it doesn’t display the theme image under Additional Themes. Instead I get this warning:-

    Warning: Invalid argument supplied for foreach() in /home/mysite/public_html/wp-admin/themes.php on line 98

    Line 98 of themes.php is:-

    foreach ( $table as $row => $cols ) {

    I did a search on the forums here and came across a suggestion at:-

    So I tried this:-

    if (is_array($table) || is_object($table))
    foreach ( $table as $row => $cols ) {

    Which gets rid of the warning but doesn’t display my new theme under Additional Themes.

    I’d be grateful for any help…thanks,


Viewing 1 replies (of 1 total)
  • FYI I uninstalled classic and default themes. I thought reinstalling them might help but I still get the same warning with the unamended themes.php

Viewing 1 replies (of 1 total)
  • The topic ‘Strange error after upgrading to v2.6’ is closed to new replies.