Support » Plugin: Polylang » Strange duplicate post with polylang and jetpack

  • Resolved NorysLintas


    Hi i don’t know what plugin do this strange issue,jetpack or

    polylang, but i’ll post the same thing both support forum.
    Here is my configuration:
    WordPress version is 3.5.1
    Jetpack Only for Admins 1.1
    Jetpack Version 2.2.2
    Polylang 1.0.4

    Here is the test site with infinite scroll enabled by pushing the

    When i push the button “older entries” for each post there will

    be a fake duplicate post. In my case i have two english post and

    there are two “fake duplicate post”, if i’ll post another one in

    english section when i push the “older entries” button, there

    will be three “fake duplicate post”
    The screenshot explain better i suppose:

    If i disable the infinite scroll function and i use the wordpress

    standard older entries, no “fake duplicate post” will appear.
    For example in my official website:

    Sorry for my bad english

    Thanks for your attention 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • Jeremy Herve


    Jetpack Mechanic

    Can you reproduce the issue when switching to one of the default themes, like Twenty Eleven or Twenty Twelve?

    I checked your site, but IS doesn’t seem to be activated there.

    Sure in bookandnegative isn’t activated because is a working site, but graphene theme 1.8.4 was affected.
    I’m sorry but bookandnegative is tabu, every change in this site will pass always from the test site.

    In filmandnovel was Twenty eleven 1.5, now is Twenty twelve 1.1,same results with twenty ten

    Plugin Author Chouby


    Could you try to add this code in a custom plugin:

    add_filter('infinite_scroll_ajax_url', create_function('$url', "return add_query_arg(array('lang' => pll_current_language()), \$url);"));

    I’ll do in my test site, but where i have to put this code?
    Now i try inside polylang, then in function.php, but i have no idea where this will putted XD

    Plugin Author Chouby


    It should work in functions.php but modifications done to this file will be erased when you’ll update your theme.

    Just copy the code below in a text file:

    Plugin Name: My customizations
    if (function_exists('pll_current_language'))
    add_filter('infinite_scroll_ajax_url', create_function('$url', "return add_query_arg(array('lang' => pll_current_language()), \$url);"));

    name the file myplugin.php, upload the file in ‘wp-content/plugins’ and activate the newly created plugin.

    Unfotunately it doesn’t work,

    Plugin Author Chouby


    If you are on a test site, can you can try the development version of Polylang 1.1 (not for a production site yet) ?
    You will have to remove the plugin I asked you to create.

    Hi i tried the version 1.1dev12 and i got this error:

    When polylang is actived, the button load more post doesnt work anymore, i don’t get other post, simply i get a refresh but no more post load (you can see this on the site)
    Theme twenty eleven Version 1.5
    Thenty twelve Version 1.1
    Jetpack Version 2.2.2

    I tried to upgrade jetpack to 2.2.5, but the problem still persist.
    Thanks for your attention

    Plugin Author Chouby


    I may have found the problem. Could you please update to the latest development version (1.1dev13)?

    It probably still won’t work. You will have to resave the posts that you have translated. Unfortunately, the bulk edit won’t help, but the quick edit will do the job.

    The reason for the bug is that in previous versions, Polylang synchronizes only the ‘post_date’, not the ‘post_date_gmt’. And Jetpack does use this ‘post_date_gmt’ in its query which, together with the Polylang bug, leads to unexpected results.

    I tried the 1.1 official version, didn’t work.
    I tryied first to resave with quickedit, then i deleted all post and recreated other post both in english and in italian area.

    Plugin Author Chouby


    Could you describe your installation:
    Permalinks settings?
    Polylang settings?
    Did you try with all other plugins deactivated (including other modules of Jetpack)?

    Main configuration
    WordPress version is 3.5.1
    Jetpack Version 2.2.5
    Polylang 1.1
    No other plugin enabled, and no other plugin installed.

    1)Theme twenty eleven Version 1.5
    Thenty twelve Version 1.1
    3)Yes only jetpack and polylang are active, all modules of jetpack are disabled, infinite scroll is the only enabled.
    Polylang settings:
    2 Menu, 1 italian, 1 english
    Browser check language
    Italian default language
    Remove language from pretty permalink
    Hide the language from url for the defaul language
    Media translation and language active for media
    No synchronization

    In these days i try to enable theme function infinite scroll for other theme, but i don’t think this is the problem that cause the error.

    Plugin Author Chouby


    I spent quite a lot of time trying to debug the issue. I came to the conclusion that the filter ‘infinite_scroll_ajax_url’ is currently not usable. I opened a bug report. See #1739-plugins
    I will try to find a workaround.

    Plugin Author Chouby


    I may have found a workaround. Could your try the new development version (

    Sorry for the late reply, but i tried now the 1.1.2 version and it works well.

    Problem solved, many thanks 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Strange duplicate post with polylang and jetpack’ is closed to new replies.