• Resolved caygri

    (@caygri)


    Hi!

    In homepage Wp Portfolio appear this:

    Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 788
    
    Warning: fopen(/data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/cache/876407baf02c9db254a5c5a3958e24cd_036eab42571c65137759a104a340a182.png): failed to open stream: Permission denied in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 799
    
    Warning: fputs() expects parameter 1 to be resource, boolean given in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 800
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 801
    
    Warning: imagepng(/data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/cache/876407baf02c9db254a5c5a3958e24cd_036eab42571c65137759a104a340a182.png): failed to open stream: Permission denied in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 233
    
    Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 788
    
    Warning: fopen(/data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/cache/93eef4d4d9b03f5e0aa43ff15a8e6ad4_036eab42571c65137759a104a340a182.png): failed to open stream: Permission denied in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 799
    
    Warning: fputs() expects parameter 1 to be resource, boolean given in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 800
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 801
    
    Warning: imagepng(/data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/cache/93eef4d4d9b03f5e0aa43ff15a8e6ad4_036eab42571c65137759a104a340a182.png): failed to open stream: Permission denied in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 233
    
    Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 788
    
    Warning: fopen(/data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/cache/dc1f597d63d3aeca044b4cafb3eea948_036eab42571c65137759a104a340a182.png): failed to open stream: Permission denied in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 799
    
    Warning: fputs() expects parameter 1 to be resource, boolean given in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 800
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 801
    
    Warning: imagepng(/data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/cache/dc1f597d63d3aeca044b4cafb3eea948_036eab42571c65137759a104a340a182.png): failed to open stream: Permission denied in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 233
    
    Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 788
    
    Warning: fopen(/data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/cache/74fcf6479f484be47904f57c23349f75_036eab42571c65137759a104a340a182.jpg): failed to open stream: Permission denied in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 799
    
    Warning: fputs() expects parameter 1 to be resource, boolean given in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 800
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 801
    
    Warning: imagejpeg(/data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/cache/74fcf6479f484be47904f57c23349f75_036eab42571c65137759a104a340a182.jpg): failed to open stream: Permission denied in /data/vhosts/provatoo.net/caygri.com/wp-content/plugins/wp-portfolio/lib/thumbnailer.inc.php on line 233

    What does it mean? And how to fix it?

    https://wordpress.org/plugins/wp-portfolio/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author puravida1976

    (@puravida1976)

    Hello caygri,

    In short, it basically means that the plugin cannot access the Internet to download the captures and display them.

    The important part of the errors is:

    “cannot be activated when an open_basedir is set”

    You have enabled open_basedir (or your hosting provider did by default) and that is preventing outside connections FROM the server. You need to disable it or provide the script a workaround (I am not familiar with any workarounds myself).

    If you disable that and still cannot connect, you may also need to modify /etc/php.ini (or your PHP settings file) with:

    allow_url_fopen = yes

    *If it is currently set to “no”

    Hopefully that will point you in the right direction. Please post a follow-up, if you continue to have issues after making those changes.

    Sincerely,

    Brandon

    Yes! I fix it with my hosting provider!

    Thank you for your quickly answer!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Strange Code’ is closed to new replies.