WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
Strange characters in search page results: %1s and %2s (8 posts)

  1. ashtonej
    Member
    Posted 10 months ago #

    I get strange characters in the title of search results.

    Here's an example:

    %1sResultados de la búsqueda: %2s principiante

    The site is in Spanish.

    How can I fix this and get rid of the %1s and %2s strings?

    I have es_ES mo and po files in the wp-content/languages directory.

    I tried looking at things using the "Codestyling Utilization" plugin. There was no translation for "Resultados de la búsqueda" so I added one and nothing changed.

    I use the "WordPress Language" plugin to control my control panel language and the site display language.

    If you need to test anything use:

    http://www.masterenglishebc.com/wordpress/?s=principiante

    If this gives a page not found (we will be moving the site to the main directory soon) use:

    http://www.masterenglishebc.com/?s=principiante

    Thanks for any light you can shed on this.

    Jim

  2. ashtonej
    Member
    Posted 10 months ago #

    Sorry, here's an addition.

    If I click a category, the header also has a %s character in it:

    Archivo Categorías: %s Cursos online inglés

    http://www.masterenglishebc.com/wordpress/category/jos-blog-en-ingles/

    or if you you get a 404, use ->

    http://www.masterenglishebc.com/category/jos-blog-en-ingles/

    Some more debugging info. I thought it may be a base language install thing so I did a clean install of WP in Spanish with no plugins at all.

    The only things installed were WP and Customizr (no plugins and no child theme).

    The search still came up with the same result containing %1s and %2s.

    Sin %1sResultados de la búsqueda: %2s principiante

  3. d4z_c0nf
    Member
    Posted 10 months ago #

    About resultados, I think is a problem of the plug-in, about the Archive Category issue, is an error in the customizr translation files.
    But you should be able to solve playing with that plug-in or changing it. :)

  4. ashtonej
    Member
    Posted 10 months ago #

    Changing it is not an option.

    I hope the author can help.

  5. d4z_c0nf
    Member
    Posted 10 months ago #

    customizr/lang/es_ES.po (you can use po editors to change and compile it)

    Error about "Resultados" is here:
    line: 1289

    the other one about "Archivo Categorías: %s" is here:
    line: 1302

  6. ElectricFeet
    Member
    Posted 10 months ago #

    It's a known bug, not yet fixed, unfortunately.

  7. ElectricFeet
    Member
    Posted 10 months ago #

    No, I was wrong there. Archivo Categorías seems to have been resolved in the latest version.

    "Resultados de la búsqueda" is still an issue however. I've sent the new .po and .mo files to Nicolas, for the next version.

    In the meantime, you can fix your own by following the instructions that I gave in here.

  8. csingerline
    Member
    Posted 10 months ago #

    Would someone please take a look at my post and let me know if there is anything I can do to fix my website?

    This was supposed to be launched today but I made a small change the the php file and now it is completely crashed. Any advice would help!

    https://wordpress.org/support/topic/problem-with-customizr-theme?replies=1

Reply

You must log in to post.

About this Theme

About this Topic

Tags