Strange Canonical issue (1 post)

  1. uisneach
    Posted 3 years ago #

    I have built a WordPress plugin and included the action hook to remove the default canonical link that WordPress adds to pages.
    remove_action('wp_head', 'rel_canonical');
    That works fine on most installations where I have added the plugin and the link gets removed. However, its not removing the link for one WordPress website running 3.2.1 and using the Agentpress theme (Genesis child).

    I have tried adding the code to remove the link to the bottom of the Theme's functions file but still no joy.

    The canonical url is not being added to the website by any other plugin (SEO or otherwise), and shows up in the code just before the ending </head> tag.

    Does anyone know if themes like Genesis also add a canonical link, and what hook would be required to remove it?

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 3 years ago by SocialBlogsite
  • This topic is not resolved
  • WordPress version: 3.2.1