Support » Alpha/Beta » [Resolved] Strange Bug: Can’t edit; Keep being redirected to slug

[Resolved] Strange Bug: Can’t edit; Keep being redirected to slug

  • I cant edit no post. if I click edit, It loads the toolbar and the page and redirects me to the slug. What the heck?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Fixed.

    How ?

    I encountered the same problem, with WP 2.0 RC1, RC2 and RC3 installed today. I once disabled all my plugins and the problem was still there. ch0de, or someone else, who can tell me how to fix this strange problem? thanks in advance.

    AS far as I found out, a few people do have this problem – no matter if they use customized versions or not.

    So chode, please, post your solution and not only “fixed”.

    Well, I had the problem as well, but it “fixed itself” after I installed “one more plugin” – UTW….

    I’m not trying to be funny. That’s exactly what happened. This is on 2.0 beta 1, and no, I have NOT upgraded, nor am I going to any time soon (not even to the release version when it happens): this is a clear case of “if it ain’t broke, DON’T FIX IT. This version is working perfectly – since it “fixed itself”. End of story.

    I also used UTW, but not lucky as vkaryl.

    beta 1 is broke. 🙂 That’s why there are newer versions. 🙂

    Yup. But this one little thing for me is now fixed, and I’m not willing to deal with all the other stuff that’s now being problematic….

    But that’s just moi, you know. Others of course opt differently.

    I did finally update to RC3 – which immediately produced this problem again. This time I deactivated all the plugins (verified that it worked without them), then reactivated one at a time until it quit working again.

    The culprit is SEM Frame-Buster in my install specifically. YMMV.

    Ah yes, with the live preview a over-enthusiastic frame buster might bust you out of your own site.

    Gosh – what an interesting comment….

    Btw, happy holidays of whichever version is your preference, to you and all the dev team, and your families.

    Thank Matt. So can you fix this matter, or can I just turnoff the live preview function?

    BTW, Merry Christmas to all here.

    I had the same redirection problem. I removed in posts.php

    the following lines (lines 83 t/m86) to deactivate the i-frame :

    <div id='preview' class='wrap'>
    <h2 id="preview-post"><? php _e('Post Preview
    (updated when post is saved)'); ?> <small class="quickjump">

    <?p hp _e(' edit ↑'); ?>

    <i frame src="<?php the_ perm alink(); ?>
    " width="100%" height="600" ></iframe>

    and installed the preview plugin of Martin Chlupá? at :

    Wow. Thanks Mazalien!

    I finally found the problem: I was using a redirection script and forgot about it a long time ago.

    Whenever the page preview inside die iframe loaded, it redirected me to the post itself. Damn, am I stupid.

    AleXP the remedy may be worse than the disease. I liked the idea of such a preview-pane very much. Its a pitty that it causes such errors. I hope the developers are goin to investigate this problem and come up with a brilliant insight.. :)-

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Strange Bug: Can’t edit; Keep being redirected to slug’ is closed to new replies.