Support » Plugin: Web Stories » Story Archive Broken

  • Resolved Damien

    (@damienmaurer)


    Hi guys,

    With the last version of the plugin, any new story do not appear in the archive pages.

    Is there an issue with the creation of the thumbnail for the poster (I know the regular posters don’t work, but the “Link to a File” option sort of works).

    Note that it happens when:
    – Creating a new story from scratch
    – Duplicating an existing story
    – Saving an old story (no change, just save)
    It happens on my 3 websites running the last version of the plugin

    Note that on regular archives, nothing is shown. With an Elementor archive, there’s a empty Div.
    The SQL Query does retrieve the post ids from wp_posts.

    It looks like on save, there thumbnails of the poster aren’t generated, the divs do not have the “has-post-thumbnail” CSS class.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter Damien

    (@damienmaurer)

    Yeah, it doesn’t generate the postmeta _thumbnail_id…

    It even removes it from an old story that had it on save.

    Plugin Support Luckyna San

    (@luckynasan)

    Hello there, @damienmaurer. Thanks for posting your topic. Can you please confirm if you are still seeing this issue after updating to version 1.23.1 which was released today?

    Thread Starter Damien

    (@damienmaurer)

    It’s fixed for selecting a photo in the library, not link to file.

    For existing stories created with 1.23, just saving the story doesn’t add the image/generate the thumbnail, you have to go and select it in the library again for the plugin to save the _thumbnail_id in postmeta.

    But selecting Link To File doesn’t save the _thumbnail_idat all. It looks like the thumbnail was an oversight in this new feature 🙂

    Plugin Author Pascal Birchler

    (@swissspidy)

    But selecting Link To File doesn’t save the _thumbnail_id at all. It looks like the thumbnail was an oversight in this new feature 🙂

    A hotlinked poster image does not have an ID, so that is technically correct.

    However, you’re right in that we should be filtering the has_post_thumbnail() function in WordPress to make sure things like dynamic has-post-thumbnail CSS classes work (assuming that your theme uses has_post_thumbnail() for that and not get_post_thumbnail_id() directly)

    We’ll look into it!

    Plugin Support Luckyna San

    (@luckynasan)

    @damienmaurer Feel free to monitor this GitHub ticket for progress on the above work: https://github.com/GoogleForCreators/web-stories-wp/issues/12028.

    We’ll close your topic here, but do feel free to reach out with any more questions. Thanks!

    Thread Starter Damien

    (@damienmaurer)

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Story Archive Broken’ is closed to new replies.