Support » Theme: Storefront » storefront not working properly

  • Resolved leamingtone

    (@leamingtone)


    I have switched from mystile to storefront and I can not customise my site now. When I make a change and click publish I get an message saying “Looks like something’s gone wrong. Wait a couple of seconds, and then try again.”

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi there,

    Have you tried clearing your browser cache (steps on how to do that here if you’re using Chrome) then attempting to customize your site again?

    If the issue persists, please open the inspector tool (right-click - Inspect if you’re using Chrome) and make note of any errors that are displayed there.

    EDIT: I found this old forum topic which might be helpful to you.

    James
    Designer @ Automattic

    • This reply was modified 8 months, 2 weeks ago by  James Koster.

    Hello James, thank you for getting back to me.

    I have 2 websites, both using Storefront. One of them, musicalmotors.com is working fine.

    The other, tonethecone.com is having problems.

    For example if I go Dashboard – Appearance – Customise – Footer, then change the background colour from grey to yellow. The footer changes colour to yellow but when I press Publish I get a message ” Looks like something’s gone wrong. Wait a couple of seconds, and then try again” When I try again I get the same message. When I navigate away I get a message “The changes you made will be lost if you navigate away from this page” I click ok and the changes are lost.

    Any thoughts on the matter ?

    Hey,

    Did you find any javascript errors when you opened the Inspector?

    Honestly that sounds like a poorly configured Customizer control. Have you installed any plugins that interact with the Customizer? If so, try deactivating them.

    Also try switching themes and see if the Customizer is still not working.

    We’re essentially trying to eliminate different potential causes of the issue, normally this will be in the theme or plugin, but since Storefront (vanilla) is stable right now it seems unlikely that it will be at fault.

    Let me know how you get on.

    James
    Designer @ Automattic

    Hello James

    I have changed Themes and still get the same problem. I started deleting a couple of plugins and now when I go to cusomize I get a message

    “Fatal error: Allowed memory size of 62914560 bytes exhausted (tried to allocate 3072 bytes) in /homepages/6/d232479725/htdocs/clickandbuilds/CMS0/wp-admin/includes/class-wp-list-table-compat.php on line 35”

    Now what do I do? any help would be much appreciated.

    Tony

    Job

    (@jobthomas)

    Automattic Happiness Engineer

    Hey @leamingtone – given that it happens with all themes you’re trying means that this isn’t related to Storefront. That said, it seems that you have a problem with the WordPress memory setting.

    Here’s a tutorial on how to fix that: https://www.wpbeginner.com/wp-tutorials/fix-wordpress-memory-exhausted-error-increase-php-memory/

    If this doesn’t fix it, please open a thread on the general WordPress forums as this is no longer one that’s connected to Storefront. Thanks!

    Thanks for your help and pointing me in the right direction.

    Tony

    laceyrod

    (@laceyrod)

    Automattic Happiness Engineer

    Hi there,

    Glad this helped! Since it’s been a while, we’re going to go ahead and mark this thread as “Resolved”, but please feel free to open a new thread if you have any further questions.

    Thanks!

    Theme Author Automattic

    (@automattic)

    Resolved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘storefront not working properly’ is closed to new replies.