Support » Plugin: WordPress Popular Posts » Stopped working two days ago?

  • Resolved templederr

    (@celebtemple)


    Hello, I am using this plugin for a long time and always worked flawlessly, but since two days ago, I only see “Sorry. No data so far.” I have tried everything I know, switching browsers with VPN..etc. I am using the same plugins, including WordPress Popular Posts since I started the site.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 30 total)
  • Same here. I’m using WP Rocket as a caching plugin. After several trys I’ve downgraded to 5.1.

    The link to my site is https://travellingcarola.comhttps://travellingcarola.com

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @celebtemple and @cbrunnbauer,

    In @celebtemple’s case, please read this FAQ. Chances are @cbrunnbauer had the same issue but since they downgraded to a previous version of the plugin I can’t tell for sure.

    I don’t have caching plugin.
    Active plugins: Akismet Anti-Spam 4.1.6, Featured Image from URL 3.1.8, Google XML Sitemaps 4.1.0, Grow by Mediavine 1.7.0, Merge + Minify + Refresh 1.10.11, Multi-column Tag Map 17.0.10, Slim SEO 3.4.3, WordPress Popular Posts 5.2.1, Yuzo – Related and List post (Free version) 6.2.2

    Theme: GeneratePress (2.4.2) by Tom Usborne

    Plugin Author Héctor Cabrera

    (@hcabrera)

    You seem to have a plugin that minifies code though, @celebtemple: Merge + Minify + Refresh. Some hosting providers (like WPEngine, SiteGround, etc.) also provide their own caching system so you’ll want to check that as well.

    I have already disabled all plugins, including Merge + Minify + Refresh, and nothing happened. I’m using Hostgator and they do not have a cache system.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    I still see JS code being minified on your website, @celebtemple:

    The path to the minified file is:

    https://imgtrend.com/wp-content/mmr/04f71420-1594630112.min.js

    From the mmr in the URL part my guess it’s the Merge + Minify + Refresh plugin as I pointed out earlier.

    I have disabled Merge + Minify + Refresh plugin again and I will wait for you to see.

    Ok, I can see that is a problem in Merge + Minify + Refresh plugin. Can you fix from your side, or can you give me a path to add in Merge + Minify + Refresh plugin to exclude WordPress Popular Posts plugin from minifying?

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Please add these lines to the textarea under Ignore these files (one per line):

    https://www.my-domain.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.js
    https://www.my-domain.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.2.1.min.js
    https://www.my-domain.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js

    Replace www.my-domain.com with your actual domain name (in your case @celebtemple, that would be imgtrend.com), then click on the Save button to apply changes.

    Remember to clear MMR’s cache (click on Purge All) for these changes to take effect.

    Hi, thank you for your help. I will test now. I have notified the author of Merge + Minify + Refresh plugin about this issue here: https://wordpress.org/support/topic/wordpress-popular-posts-not-working-after-latest-update/#post-13121678

    Thank you. I tried to follow the FAQ. But I’m not experienced enough to solve the problem. Apart from deactivating WP Rocket and Short Pixel AI I also intended to exclude WPP’s JavaScript by trial and error. Up to now I don’t get any data with 5.2.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @cbrunnbauer,

    It seems that WPP’s script is in the right place now, not really sure why it’s not working so you’ll have to help me out for a bit.

    Please go to your WP Dashboard > Settings > WordPress Popular Posts > Debug, share the information you see there with me (you can copy&paste it here or take a screenshot and share it with me, either way should be fine.)

    Performance Nag: Inactive

    Log Limit: No

    Log Views From: Everyone

    Data Caching: No

    Data Sampling: No

    External object cache: No

    WPP_CACHE_VIEWS: No

    System Info
    PHP version: 7.3.19

    PHP extensions: Core, date, libxml, pcre, Reflection, SPL, hash, session, cgi-fcgi, standard, recode, apcu, bcmath, bz2, calendar, ctype, curl, dba, dom, mbstring, fileinfo, filter, ftp, gd, gettext, gmp, gnupg, mysqlnd, iconv, imagick, intl, jsmin, json, ldap, exif, mcrypt, mysqli, odbc, openssl, pcntl, PDO, pgsql, posix, pspell, readline, SimpleXML, snmp, soap, sockets, sodium, sqlite3, ssh2, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, xml, xmlwriter, yaml, zip, zlib, imap, mailparse, mongodb, PDFlib, pdo_dblib, pdo_mysql, pdo_pgsql, pdo_sqlite, Phar, scrypt, wddx, xmlreader, xmlrpc, xsl, Zend OPcache

    Database version: 10.3.23-MariaDB-log

    InnoDB availability: DEFAULT

    WordPress version: 5.4.2

    Multisite: No

    Active plugins: 404page – your smart custom 404 error page 11.2.3, Advanced Custom Fields 5.8.12, Advanced Custom Fields: Gallery Field 2.1.0, Advanced Custom Fields: Repeater Field 2.1.0, All Meta Tags 4.39, Antispam Bee 2.9.2, bananacontent 2.6.0, Block Bad Queries (BBQ) 20200706, Booking.com Product Helper 1.0.0, Borlabs Cookie – Cookie Opt-in 2.2.3, Broken Link Checker 1.11.13, Contact Form 7 5.2, Disable Google Fonts 2.0, Easy Facebook Like Box 4.1.1, Easy Social Share Buttons for WordPress 7.2, Easy Theme and Plugin Upgrades 2.0.1, Envira Gallery 1.8.9.9, Envira Gallery – Defaults Addon 1.4.8, Envira Gallery – Protection Addon 1.3.4, Envira Gallery – Social Addon 1.6.1, Envira Gallery – Watermarking Addon 1.4.2, FV Player 7.4.24.727, GetYourGuide Widget 1.2.6, Gutenberg Blocks by Kadence Blocks – Page Builder Features 1.8.7, Kirki Customizer Framework 3.1.4, Loco Translate 2.4.0, LuckyWP Table of Contents 2.1.3, ManageWP – Worker 4.9.7, Marni Custom Post Types 1.0, Marni Meta Boxes 1.0, Marni Share Buttons 1.0, Marni Shortcodes 1.0, Marni Widgets 1.0, Matomo Analytics – Ethical Stats. Powerful Insights. 1.1.3, Meta Box 5.3.2, Rank Math SEO 1.0.45, Really Simple SSL 3.3.4, Really Simple SSL pro 2.1.21, Scale Large Image Threshold 1.2, SendPulse Free Web Push 1.3.0, ShortPixel Adaptive Images 2.0.2, ShortPixel Image Optimizer 4.19.3, Smash Balloon Instagram Feed 2.4.5, Widget Options 3.7.4, Wordfence Security 7.4.9, WordPress Popular Posts 5.2.1, WP Health (Formerly My WP Health Check) 1.8.11, WP Retina 2x Pro 5.6.1, WP Revisions Control 1.3, WP Rocket 3.6.2

    Theme: Marni (2.02) by red_sun

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Thanks, @cbrunnbauer.

    I’m 80% sure that the issue is caused by some setting in WP Rocket (but I’m not really familiar with it, it’s paid plugin after all). To confirm this, please disable WP Rocket for a moment and leave a comment here when it’s done so I can have another look. Don’t enable it back until we figure out what’s going on, alright?

    Alright, it’s disabled now

Viewing 15 replies - 1 through 15 (of 30 total)
  • You must be logged in to reply to this topic.