Support » Plugin: Popup Maker - Popup Forms, Opt-ins & More » stopped working, suddenly – WP 4.5?

  • Resolved Glenn

    (@rglennnall)


    just upgraded last night. today the popup doesn’t work. not sure if it’s related, but seems likely, as i’ve done nothing else with related files.

    I’m using a class trigger, and the class is still present on the link. can’t think of any other thing.

    no other reports than mine and the previous?

    https://wordpress.org/plugins/popup-maker/

Viewing 15 replies - 1 through 15 (of 40 total)
  • Plugin Author danieliser

    (@danieliser)

    @glenn – Only one other report and theirs ended up being an issue caused in another plugin.

    Do you have a link where it should be working?

    yes, several – i was hoping you’d ask –

    http://thereeferexchange.com/the-reefer-exchange/ – the posts titles and imgs are where you helped my put the dynamic triggers and content in the other post. worked great until today. and the code is still in the page, the a link class and the hidden divs…

    i created a new test popup earlier today to just fire when the home page opens. and it doesn’t. i’m guessing there’s a javascript clash somewhere:

    http://thereeferexchange.com/

    i turned off the login restriction for the first page, let me know if you can’t get to it. there are just two posts in a grid…

    Hi there,

    I’m also having issues with my popup suddenly not working. I have not updated my site to 4.5 yet.

    Here is the page with the button:

    https://www.aquorwatersystems.com/shop/

    The code I am using for the contact button in the sidebar:

    [button shape="square" size="regular" float="none" class="popmake-contact-popup"]Contact Us[/button]

    I also tried using this code (doesn’t work):

    [popup_trigger id="9363" tag="button"] Button Text [/popup_trigger]

    Thanks for your help in advance.

    Daniel asked me for links to where my problems are, leading me to believe that he was going to look at them.

    Have not heard back from him, so…

    I’m convinced a scripting error has cropped up. ALL of my popups have simply quit working, and new ones I create don’t work.

    I’ve installed no new plugins, only updated to 4.5. I’m now looking for another popup plugin and correcting my Rate and Review.

    Plugin Author danieliser

    (@danieliser)

    @glenn – Sorry for the delay, I am one of the organizers for WordCamp Jacksonville FL which is this weekend so this week has been pretty hectic.

    Your site is using Divi and it appears that the Divi themes custom.js file has a jQuery error likely due to WP Core updating to the latest version of jQuery and Divi needing to update to match.

    See here near the bottom about jQuery Libraries: https://wordpress.org/news/2016/04/coleman/

    That aside I do not see a popup loaded on that page so if you disabled it just know that the error is not in Popup Maker but Divi, this is the 3rd report in 2 days with the same cause.

    I have tested thouroughly both 1.3.9 and v1.4 beta against WP 4.5 and saw no PHP or JS errors. I have been using the WP4.5 betas on my local dev server for weeks and haven’t even seen any issues with our extensions so that Divi error is the likely cause.

    Check it yourself using your browser console (F12 -> Console Tab -> Then Refresh and you will get more details).

    This is the offending line: $( ‘a[href*=#]:not([href=#])’ ).click( function() {

    And the error: jquery.js?ver=1.12.3:2 Uncaught Error: Syntax error, unrecognized expression: a[href*=#]:not([href=#])

    @aquor – Your site seems to have a JS error as well for something called WP Scroll Depth. You can get more info from browser console as well.

    Hope that helps.

    thanks so much for your help, Daniel. sorry for my harsh words.

    you provide better support than anyone. thanks again.

    A lot of older themes are getting caught out by issues like this. If you’re not seeing the popup on your site after upgrading to WordPress 4.5, check out the console message and look for the error message (example from an old site):

    jquery.js?ver=1.12.3:2 Uncaught Error: Syntax error, unrecognized expression: a[href=#top]

    It’s probably a syntax error similar to a[href=#top], an attribute selector which is not an identifier or string. That is, there are no quotation marks around the value.

    So dig around in your theme for a[href=something] and change it to a[href='something'] and you’re probably good to go.

    fantastic – i was planning on looking at it later and figuring this out myself. thanks so much for the lead.

    Daniel clued me into it earlier, too. so you guys are great.

    thanks

    yep – that did it.

    for future reference for anyone has Divi, an Elegant Theme, it’s in /js/custom.js, ~ line 3408:

    $( ‘a[href*=”#”]:not([href=”#”])’ ).click( function() { /…

    thanks again guys!

    Didn’t think to look for JS conflicts – that solved it. Thanks!

    Plugin Author danieliser

    (@danieliser)

    @aquor, @glenn, @james Barlow – Awesome, glad you got it working. Also be sure to notify the theme authors so that they can make corrections as you will not be the only ones affected :).

    @james Barlow – Thanks for stepping in with a solution. Email me support at wppopupmaker.com and I have something for you.

    Btw, If you have a moment, I would very much appreciate if you could quickly rate the plugin, just to help us spread the word.

    @glenn, @daniel,
    Also have a Divi site where this stopped function.
    What was the fix? I can see the $( 'a[href*="#"]:not([href="#"])' ).click( function() { /...

    But am not so clear on what needs to be fixed there…

    at approx. line 3408 of that file you should see:

    $( ‘a[href*=#]:not([href=#])’ ).click( function() { /…

    WITHOUT the quotes around the # …

    just add quotes around the #, like:

    $( ‘a[href*=”#”]:not([href=”#”])’ ).click( function() { /…

    and then go Rate the plugin. 🙂

    @glenn,

    Wow – thanks for the quick response.

    a) I’m going to rate the plugin a 5 right now 🙂
    b) The quotes around the hashtag is already there in the custom.js file…
    problem still persisting

    Doing some digging to see if this fix needs to be applied to another source?

    http://www.kellyraeroberts.com/shop/
    notice the image linked to popup – bottom of page says “Click here to find out more”

    Ok… so indeed – it was a duplicate call to load javascript library.

    Removed duplicate and with the Use Google Libraries – now fully functional 🙂

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘stopped working, suddenly – WP 4.5?’ is closed to new replies.