Support » Plugin: Cookiebot | GDPR/CCPA Compliant Cookie Consent and Control » Stopped Working after updating WP 5.3.1

  • I’ve updated WordPress to latest version but, the cookiebot consent stopped working.
    I’ve added the shortcode in content, The consent box was showing on clicking the link in the content. it is stopped working after updating WordPress, I’ve checked the plugin is tested upto WP 5.2.5. But when will you release an update for the latest update, What should I do to make it work with WP 5.3.1

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Johan Holst Nielsen

    (@phpgeekdk)

    Hi @umeshnevase,

    Just did a quick test – and it seems to work fine with our test setup.

    Are you able to provide me with some additional information:
    – What happens when the shortcode is added in content? Is the shortcode just outputted or nothing outputted at all?
    – Can you provide a link to the website where you are using Cookiebot?

    Regards,
    Johan

    Thread Starter Umesh Nevase

    (@umeshnevase)

    @phpgeekdk

    https://www.temporary-url.com/E6B7B
    on clicking Here in the content (end of the page), was asking me to ‘Change your consent’ or Withdraw your consent

    But now it is not working

    • This reply was modified 1 year, 11 months ago by Umesh Nevase.
    • This reply was modified 1 year, 11 months ago by Umesh Nevase.
    • This reply was modified 1 year, 11 months ago by Umesh Nevase.
    Plugin Contributor Johan Holst Nielsen

    (@phpgeekdk)

    @umeshnevase

    Okay – now I think I know what the problem.

    I works fine for me (and probably all your visitors). However – in the latest version of the Cookiebot WordPress Plugin we removed the consent banner from logged in users with “Edit Themes” capability. We did that, because Cookiebot in some cases conflicted with alternative editors like Divi and Elementor.

    Can you please check if it work when you not logged into to WordPress?

    Right now all users with “Edit Themes” capabilities automatic accepts all cookie types.

    /Johan

    Thread Starter Umesh Nevase

    (@umeshnevase)

    @phpgeekdk

    I’ve checked in incognito mode without logged in user. I’ve also checked on other browsers and my plugin is not updated to the latest. I was going to update but the issue arose.

    Did you check the URL in incognito? Is it working for you on clicking here link? I’ve checked on other browser, The hide and show for dialogue, but the links for Change your consent and Withdraw your consent are hidden

    Plugin Contributor Johan Holst Nielsen

    (@phpgeekdk)

    @umeshnevase

    Okay – so far I have not been able to reproduce the error. Can you provide me with som additional details about what browser you are using – and the OS you are running?

    I just captured a screencast of withdraw consent and change consent on your site.
    https://drive.google.com/file/d/1ZJWonF0ejedWSTpw4KAOe649itrau_wa/view

    Can you confirm it is the actions I do in the above video that doesn’t work for you?

    Thread Starter Umesh Nevase

    (@umeshnevase)

    @phpgeekdk

    Thank you for your screencast. You are doing the correct action.
    It doesn’t work for Chrome. Sometimes it works on firefox, but sometimes not. I’m using macOS Mojave 10.14.6.

    I think the issue with cookie bot js loading, sometimes it loads sometimes not.

    Please check below urls for screencast:

    on Firefox: the consent and withdraw consent URL’s are hidden,
    Firefox: https://drive.google.com/file/d/1ISywiQ_5RA4UBQO2vgKo2TIoJd15s3dz/view?usp=sharing

    on Chrome the whole container is hidden.
    Chrome: https://drive.google.com/file/d/10BrmSY1BMgZHKJTCNMlbPblbGwiypP13/view?usp=sharing

    Thread Starter Umesh Nevase

    (@umeshnevase)

    @phpgeekdk Did you get any chance to check the screencasts? I waiting for your reply.

    • This reply was modified 1 year, 11 months ago by Umesh Nevase.
    Plugin Contributor Johan Holst Nielsen

    (@phpgeekdk)

    @umeshnevase
    Yes… It seems not to be related to the WordPress plugin… but might be related to Cookiebot core…

    The problem seems to occur because you add some custom Javascript. We have not yet found an solution (or reason) for the behavior. But I will get back to you as soon as I have any updates.

    /Johan

    Thread Starter Umesh Nevase

    (@umeshnevase)

    @phpgeekdk
    Do you get any chance to check? still facing the problem

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Stopped Working after updating WP 5.3.1’ is closed to new replies.