Support » Plugin: Pushover for WooCommerce » Stopped working after latest Updates

  • This was working perfectly but has stopped. It is enabled and we were getting them before. I enabled debug and can capture some logs to help but maybe a hook broke with an update? Test notifications work fine, just nothing configured for orders or free orders

    WordPress 5.6
    WC version: 4.8.0

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Daniel Espinoza

    (@growdev)

    Hi ccolotti,

    I just checked the current version of the Pushover plugin with the versions of WP and WC you listed and I was able to receive test and New Order notifications.

    Which notifications are not working?
    Also, when a new order is created, what status does it go to (pending, completed)?

    Thanks,

    Daniel

    Thread Starter ccolotti

    (@ccolotti)

    goes into pending. oddly the test works but the actual new order (for paid and free both are checked and have been) don’t send the push…

    Thread Starter ccolotti

    (@ccolotti)

    I can setup a staging site for you to poke at…

    Plugin Author Daniel Espinoza

    (@growdev)

    A few steps to debug:

    1. Turn on logging and place an order. Check the log for output and any related error messages.

    2. The New Order code is here and is going to be hooked in to the woocommerce_thankyou hook. If you’re using a custom theme that removes that hook it won’t fire.
    Try switching to a base theme like TwentyTwenty or Storefront and place an order to see if it fires.

    Thread Starter ccolotti

    (@ccolotti)

    I will try logging, there is no custom theme and it has been working fine for some time. No special removal of the thankyou hook it’s using storefront theme pretty much out of the box. Let me try getting some logs on a staging copy.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.