Support » Plugin: Simple Custom Post Order » Stopped working after custom functions.php for woocommerce

  • Resolved eaaronross

    (@eaaronross)


    Hello,
    I was able to drag and drop posts and post tags, but I wanted to also be able to drag and drop Woocommerce Product Tags. To that end, I used some custom code in my functions.php file to try and combine the two types of tags. It did not work and it also killed my ability to reorder regular posts and post tags. I then removed the code from my functions.php file, but still I cannot reorder anything. Any idea how to reset the situation so the plug-in works? Also, is there a way to make the plug-in work for Woocommerce Product Tags?

    Here is the code I put into functions.php for reference, although it is now deleted.

    function custom_wc_add_post_tags( $args ){
    $args[‘taxonomies’] = array(‘post_tag’);
    return $args;
    }
    add_filter( ‘woocommerce_register_post_type_product’, ‘custom_wc_add_post_tags’ );

    add_filter(‘woocommerce_taxonomy_objects_product_tag’, ‘__return_empty_array’);
    add_filter(‘woocommerce_taxonomy_args_product_tag’, ‘__return_empty_array’);

    function custom_wc_remove_product_tags_column($columns){
    unset( $columns[‘product_tag’] );
    return $columns;
    }
    add_filter( ‘manage_edit-product_columns’, ‘custom_wc_remove_product_tags_column’, 15 );

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello @eaaronross

    Thank you for reaching us !

    https://gyazo.com/6a09f8b9db83a32db6b8a3497bf3b878 -> You can check the custom post types and taxonomies you need to order right from the SCPO settings
    Find these settings in the wordpress dashboard -> Settings -> SCPOrder.
    Thank you for understanding !

    Please let me know if you have some more questions !

    Have a nice day ! 🙂

    Warmly,
    Marian

    Thread Starter eaaronross

    (@eaaronross)

    Great! It’s mostly working now! The post tags are working again, and the Products Tags are now “drag and drop” as well, but nothing changes in how the product tags appear on the product pages themselves.

    I’m calling the tags like this:
    <?php echo $product->get_tags(); ?>

    Could that be the issue?

    Hello @eaaronross

    Now yes, I found your problem, I posted it on github and it will be solved, we don’t know the exact date yet.
    https://github.com/ColorlibHQ/simple-custom-post-order/issues/102

    Thank you for understanding !

    Please let me know if you have some more questions !

    All the best,
    Marian

    This topic will be marked as resolved as we have an open ticket on GitHub regarding this. Please keep in mind that the ‘resolved’ status is only for this support thread, not the issue on GitHub.

    Warmly,
    Marian

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Stopped working after custom functions.php for woocommerce’ is closed to new replies.