Support » Fixing WordPress » Stopped switching from visual editor to text editor

  • I have read through many of the discussions regarding this topic and have followed many of the suggestions without luck. My problem started only 2 days ago and so we have gone back to try to review any actions that were taken on that day to help identify issues. We didn’t find any abnormal actions were being taken on that day.
    I have done the following:
    Updated all plugins
    Updated the theme in use
    Deleted all plugins not active
    Deactivated all plugins
    Reactivated plugins one by one
    Tested different themes…same problem
    Re-installed the theme being used (Divi)
    Re-installed wordpress with exceptions of wp-content .htaccess, wp-config.php
    Turned on debug…turned off debug
    Cleared all cache memories I can find
    I still have not seen any true fix for this problem but, I also have not seen a true identification of the cause either. It seems most are just good guesses of what might work.
    So, my bottom line is I am dead in the water until I can figure out how to get into the “Text” editor to modify the code we are using.
    I would love to resolve this issue so I can move forward.
    Could this possibly be an editor issue and by installing a different plugin for the editor resolve the issue?
    Thank you for any new suggestions that might bring resolution.

Viewing 8 replies - 1 through 8 (of 8 total)
  • hey! had the same problem and fixed it by adding to “wp–includes\class-wp-editor.php” in line 177 right after the button tag opening so now it looks like this:
    $buttons .= '<button onclick="switchEditors.switchto(this);" type="button" id="' . $editor_id_attr . '-tmce" class="wp-switch-editor switch-tmce"' .

    and same in line 179 that now looks like this:
    $buttons .= '<button onclick="switchEditors.switchto(this);" type="button" id="' . $editor_id_attr . '-html" class="wp-switch-editor switch-html"' .

    onclick=”switchEditors.switchto(this);” this is what i actually added. work perfectly now.

    Hallo,

    … Thanks dimagimburg, for the quick FIX work perfectly now also for me!

    After the update to WordPress 4.3 I had the same problem:
    It is not possible to switch between the text editor and HTML editor!

    BUT I hope that is not the “majer” solution!?!
    I hope there will soon come a update from/for WP!

    sure they will fix it ๐Ÿ™‚ my hack is something temporary and of course it is better to wait for official fix by WP.
    this is minor issue, the scripts file (editor.js) which they changed is not included/loaded in the script loader ๐Ÿ™‚

    Thanks for your Info!

    Hallo,

    … now I’ve meantime WP 4.4 and this problem still exists!

    Have you infos, when they fix it?

    Thanks!

    Hallo,

    … I’ve the solution in my/for case!

    The problem is/was the plugin “PS Disable Auto Formatting”
    (http://wordpress.org/plugins/ps-disable-auto-formatting/)

    After I refixed the “wp–includes\class-wp-editor.php” (WP version 4.4) and deactivate the plugin “PS Disable Auto Formatting”, works all fine!

    (Refix: I delete the string onclick=”switchEditors.switchto(this);” from line 177 and line 179)

    Thanks!

    I also have been having the same issue:
    The wp-switch-editor.switch-html button has not been working. I am running WordPress 4.4.2 and have done all the things listed above without any effect.

    Opps. My issue was my own Security software. I simply made an exception for my own website and all the functionality is back. ๐Ÿ™‚ I had done that once before, but because of upgrading to Win10 I had not redone it.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Stopped switching from visual editor to text editor’ is closed to new replies.