Stopped receiving e-Mails (e.g. notifications) from my WordPress site (1 post)

  1. Diekleinenic
    Posted 2 years ago #

    I noticed a few days ago that I stopped receiving ANY and all e-Mails from my WordPress site including contact messages (that go through a plugin) or new user subscriptions that go directly through WordPress as well as ANY other e-Mails or notifications, not receiving a single thing.

    Does anyone have any ideas what may have caused it and even more importantly, how I can fix it??
    It is very important to me that I receive all contact messages, comment and new user notifications immediately into my e-Mail inbox.
    I made sure that all my e-Mail address everywhere are correct and I even changed it to my you@yourdomain.com e-Mail in case it had been going to spam, but it still doesn't work.
    There is not change or event on my end that I can tie to the day it stopped working. =/

    I tried to run it through STMP - I configured it Monday morning and tried to test it a few times and it didn't work. The next morning it started working, all e-Mails and notifications worked (except for my security backup and new user registration e-Mails). I tried to send another test e-Mail through STMP and all of the sudden everything stopped working again.

    I checked my error logs and the only two things I see that may be related are:
    [Thu Jan 03 11:53:19 2013] [error] [client xxx] Premature end of script headers: job_run.php
    [Thu Jan 03 12:44:51 2013] [error] [client xxx] request failed: error reading the headers

    But I don't really want to turn on debugging on my live site that gets so many visitors a day, because I am afraid of breaking something and then it would take me a while and a lot of stress to get it back live up and running. So I would like to try to resolve this without turning on debugging.
    FYI, my hosting is GoDaddy. I know, I have heard a lot of bad things about GoDaddy and I will consider switching in the future, but I currently do not have the time to do that, so I would like to try to get it fixed for now.

    There is one thing I haven't tried yet and that is changing any of my DNS settings?! I wasn't sure if I should add or change any of them to relay-hosting.secureserver.net or if the setting in the STMP plugin would make changing the DNS manually unnecessary.

    Please please please help if you know anything I can do to find out what causes the issue and how I may be able to fix it.

Topic Closed

This topic has been closed to new replies.

About this Topic