Support » Plugin: oEmbed Plus » Stopped embedding Instagram posts

  • Resolved vagsan

    (@vagsan)


    On the morning of Tuesday (June 8), we noticed that Instagram posts were no longer incorporated into our WordPress. We have the App ID and App Secret filled in correctly, and no problem with the app created on Facebook Developers.

    Does anyone already have a solution? Thank you!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Today I got this message on my Facebook development kit: “The oEmbed product has been replaced with the oEmbed Read feature”.

    If you implemented the oEmbed product before June 8, 2021, you have until September 7, 2021 to complete App Review for the oEmbed Read feature. If you have not been approved for the oEmbed Read feature by September 7, 2021, your oEmbed implementations will fail to load.

    https://developers.facebook.com/docs/plugins/oembed/

    Your problem may be related to this.

    Thread Starter vagsan

    (@vagsan)

    Thanks for the answer! But if I have until September 7, 2021 to make this “fix”, why are Instagram posts already failing during embedding? Does not make sense.

    I discovered that we now need to occasionally complete “Data Use Checkup” in the Developer console in Facebook. Apparently they throttle and disable API calls until you complete.

    I was having similar issues suddenly and after a quick check and submission of the data use checkup checklist am back in operation.

    Thread Starter vagsan

    (@vagsan)

    Good, Stephan! I did these checks and it started working again. I hope it stays that way. Thanks for your help 🙂

    Hey all, I’m wondering how long it took to start working again for you?

    On your advice, I went to my developer console and saw that I was also long overdue for one of these checkups.

    For anyone else:

    – I went to https://developers.facebook.com/
    – I went to my Alerts inbox
    – I opened an alert about Data Use Checkup
    – I clicked START CHECKUP
    – I followed the instructions

    For those that have it working again:

    Did it start working right away? After an hour?

    It’s been about 15 mins since I successfully did the checkup, but my Instagram embeds are still failing to load.

    Quick update: It seems like in addition to the “Checkup”, I am also being forced to go through the app approval process mentioned above, even though it’s nowhere near September 7.

    The whole interface within Facebook is truly horrible, and it’s very hard to answer the questions in the review request because they are so irrelevant to the oEmbed tools we’re actually using, but I think I got through it.

    The reason I think that is the thing I need to do is the JSON results I get from the API calls that the plugin is making.

    {
     error: {
      message: "(#10) To use 'Oembed Read', your use of this endpoint must be reviewed and approved by Facebook. To submit this 'Oembed Read' feature for review please read our documentation on reviewable features: https://developers.facebook.com/docs/apps/review.",
      type: "OAuthException",
      code: 10,
      fbtrace_id: "AcDWoE1UtFA4v-0L6C87qCO"
     }
    }

    Normally you wouldn’t see this, but I logged the URL being requested and checked it manually to see the output.

    If anyone is having this issue and can check the equivalent let me know what you find. I don’t trust Facebook at all to get these errors right.

    So the app review actually finished within a day or so, and my app is now marked as “Live” under “App Review Status”, BUT it still doesn’t work. I continue to get the same “OAuthException” error I pasted above, 3 days after the app was accepted in both App Review (to avoid the September deadline) and a data checkup.

    Starting to wonder if there IS a bug in the plugin. No matter what I do I get the same error.

    If I set a completely invalid set of API credentials, I get an error that the account is invalid, so it’s at least differentiating between accounts and probably has identified my account, it’s just wrong about me not having passed the review process.

    Related issue:

    https://wordpress.org/support/topic/facebook-app-review-rejects-my-oembed-url/

    In that one someone already tried talking to a support person, and was told to put their app in development mode, which is insane but interesting. Mine is already in development mode and always had been, so this is probably not my issue.

    Update: On my bug report to facebook:

    https://developers.facebook.com/support/bugs/528062961705144/

    They claimed the following:

    Looks like your business verification process is not completed. Please complete the business verification process and then try again.

    More details can be found here:
    https://developers.facebook.com/docs/development/release/business-verification/

    Now I have never had a verified business and this plugin has worked for months. They never sent me a notification about this becoming a requirement, despite the many messages they’ve been sending about “Oembed Read”.

    I really don’t want to go through this process if I don’t have to, as it’s a hassle and my org has been annoyed in the past by the effects of being in a “business account” or whatever.

    My question to those for whom it is and isn’t working: Is your FB “app” in a “verified business”?

    Thanks in advance for your answers. I suspect this really isn’t the key issue.

    Update: After I confronted them about the fact that there is no reference to business validation in my error or in the description of oEmbed, they came back with this:

    I just noticed that your app is in development mode. Please be informed that as per this URL https://developers.facebook.com/docs/instagram/oembed/, instagram_oembed endpoint requires a Facebook app in Live mode to use the oEmbed Read feature. You will need to meet all the requirements before start using instagram_oembed.

    Indeed, that was the problem for me that was making it not work even though I had been approved.

    Likely this was also the reason it didn’t work after I did my Data Checkup, and it would have worked if I’d done my checkup and ensured the app wasn’t in dev mode.

    Hope this helps some others. I’m going to pressure them to fix the actual bugs with the JSON error which was falsely reporting the problem as related to app review.

    Thread Starter vagsan

    (@vagsan)

    Thank you for sharing your experience in this topic, Jer Clarke! It will certainly serve to help other webmasters without as much experience as I identify what may cause new problems in the future.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Stopped embedding Instagram posts’ is closed to new replies.