• Resolved badgoat

    (@badgoat)


    February 2nd was the last time ROP automatically posted to FB and Twitter. Prior to this date ROP worked like a charm and posted automatically as I had set up. No new plugins were installed, nothing has changed on my website, and at the time it had stopped working no plugins were even updated or required an update.The sharing log still works, but the log shows no posting activity. I have it set up to post every 6 hours. If I create a new post, ROP will post that to the social network websites without issue. Just automatic posting does not work. I have tried using both remote cron and local cron with the same results. I have tried deactivating other plug ins, uninstalled and re-installed ROP, all with the same results.

    The set up I had and use for ROP is use remote cron, post every 6 hours, no minimum or maximum on posts age, and I do have an account with cron-job.org that shows the cron job is successful every 10 minutes and without error.

    Any ideas on what happened and how I can get ROP to work again? Thank you.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    Hi there, this might require some deeper debugging on our part, can you please send us a support ticket here? https://revive.social/direct-support/

    We’ll better be able to assist.

    I also ran into this problem. It happened around the time (feb 1 or 2nd) I set my domain to force https if that matters. I will enter a ticket.
    Get an error: Could not fetch future share timer.

    Thread Starter badgoat

    (@badgoat)

    UPDATE: ROP is now auto posting to my FB and Twitter accounts as scheduled. I changed the Cron Job Type to “Local Cron”, and at cron-job.org I have set the my account to schedule a cron job every 10 minutes. Cron jobs always come back successful with no problems.

    My wordpress is updated to the latest version 5.6.1 and I am using php version 7.3.12. GoDaddy Managed WordPress.

    I did not edit my wp-config.php file per the instructions found here: https://docs.revive.social/article/686-fix-revive-old-post-not-posting

    It seems to me the “Remote Cron” setting for cron job type is not working. It used to, just doesnt work as of now. All the same rules apply per my original post. I made no changes to my website nor added any conflicting plug ins. Hope this helps.

    Vladi

    (@loveinlions)

    Thank you @badgoat for sharing the solution. It helped to get this thing going. However, I get the error status “Response data too big” on each job. Someone mentioned that cron-job.org needs a very small response, so as simple as an OK answer but I am not sure how to set it up. Do you have any idea how to have the cron get a simple OK response instead of getting the full fetched data from the url?

    @uriahs-victor I confirm that the remote cron (revive’s one) does not work.

    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    @loveinlions Did you turn off the remote cron? We can confirm that it doesn’t work for all users. When using cron-job.org please turn off the remote cron feature back to Local Cron in General Settings on the ROP dashboard.

    Also make sure the link that cron-job.org is pinging is https://yourwebsite.com/wp-cron.php?doing_wp_cron that endpoint should not return nothing much if you have the request method set to “Get” in cron-job.org

    If you still have issues then please send us a support ticket here: https://revive.social/direct-support/

    Vladi

    (@loveinlions)

    @uriahs-victor You’re a star. Thank you. I confirm that everything is working properly now.

    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    @loveinlions Awesome, please feel free to leave us a review here: https://wordpress.org/support/plugin/tweet-old-post/reviews#new-post

    Vladi

    (@loveinlions)

    @uriahs-victor No probs. 👍

    Hello,

    I have a similar issue where manual posting works when publishing or updating a post with “Instant sharing” ticked, but automatic posting does not.

    I can’t see the Cron setting mentioned above. Could please tell me if I’m missing something obvious? Should it be in “General settings”?

    I’m hoping for posts older than 2 days and younger than 12 to be posted. Minimum post age is 2, maximum post age is 12, and this latter setting was set before the recent plugin version which locks it from now on was released (see other thread for explanation).

    Thank you!

    Plugin Contributor Uriahs Victor

    (@uriahs-victor)

    @wpguillaume Please create a separate thread(s) for your issues as this one has already been marked as resolved. I can see that you have a ticket here already: https://wordpress.org/support/topic/dismiss-issues-encountered-when-trying-to-share-content-on-social-media/

    Sorry about that, new thread posted here.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.