• Resolved Rui Freitas

    (@rui-freitas)


    Hi.

    My the plugin has stopped working for no apparent reason.

    For now I only have an active popup that worked perfectly in the first few days, but suddenly stopped working.

    Can you help me?

    Thank you.

    Regards,
    Rui Freitas

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @rui-freitas,

    I’m very sorry to hear that our plugin stopped working on your site.
    Do you recall if in the meantime you have installed any new plugins, switched theme or just updated something?
    Also, can you check if your popup is in “Live” mode:

    I tried to check your site, but URL you gave is not correct.

    kind regards,
    Kasia

    Thread Starter Rui Freitas

    (@rui-freitas)

    Hi Kasia.

    Thank you and sorry, I writed the wrong link which is https://artesecontextos.com
    I haven’t updated nothing neither changed nothing important on the site’s structure.
    The popup is live.

    Best,
    Rui

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @rui-freitas,

    hope you’re doing good today! 🙂

    It seems that you’re using some kind of JS minification and that’s throwing some errors in browser’s console.
    Can you temporarily deactivate that and check your popup again?
    If that resolved the issue, let us know which optimization plugin you were using.

    Thank you,
    Dimitris

    Thread Starter Rui Freitas

    (@rui-freitas)

    Hi Dimitris.

    I use Autoptimize and W3 Total Cache and deactivated one by one and cleared the cache after each and nothing has changed.

    I am not sure if this is what you sugested.

    Thank you.
    Rui

    for future WPMU support reference; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    hope this helps debugging,
    frank (ao dev)

    Thread Starter Rui Freitas

    (@rui-freitas)

    Hi Dimitris.

    Did you give up helping me?

    Thank you.

    Regards,
    Rui

    • This reply was modified 3 years, 8 months ago by Rui Freitas.
    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @rui-freitas

    I hope you’re doing well!

    I apologize for the late reply in here. I’ve visited your site to check this issue, but I am afraid it is not online.

    Please let us know when your site will be back so we could review this issue.

    Was there any plugin/theme update done on a site before the pop-up disappeared? Please see if there is another plugin conflicting with the Hustle. Deactivate all plugins, besides Hustle and see if the pop-up is back.

    If it is back this means another plugin conflicting with Hustle, start activating one plugin at a time, until the plugin that causes this is found.

    Thank you Frank (@optimizingmatters) for chiming in, we will keep a note of this 🙂

    Let us know how it went!

    Kind regards,
    Nastia

    Thread Starter Rui Freitas

    (@rui-freitas)

    Hi Nastia

    I am truly sorry for the the late reply but I had a serious problem with my site which took me long time to solve.

    The Hustle plugin does not work when any of the following plugins are active:

    • Autoptimize
    • MailPoet 3 (New)
    • MailPoet 3 Premium (New)

    My tests site is now online if you want to check:

    https://test.artesecontextos.com/

    Please tell me what I can do about it.

    Thank you.

    Regards,
    Rui Freitas

    • This reply was modified 3 years, 7 months ago by Rui Freitas.
    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @rui-freitas

    Hope you’re doing well!

    I’ve visited your est site and a pop-up is showing up for me. Please see this screenshot.
    Would you please try and view your page with a different browser? Let us know with which browser a pop-up is not working.

    Please advise,

    Kind regards,
    Nastia

    Thread Starter Rui Freitas

    (@rui-freitas)

    Hi, Nastia.

    Thank you, but I forgot Autoptimize disabled and that’s why it worked for you.

    (And after all, MailPoet has nothing to do with this.)

    Now that Autoptimize is turned on again, it does not work and I tried in Chrome, Firefox and Opera.

    Best regards,
    Rui

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi Rui,

    Do you have file optimization enable in Autoptimize?
    Can you try disabling them one by one to see which exact option is causing it for you?
    I also tested this on my end but couldn’t replicate so it seems that issue is specific to your installation.

    Could you open up Chrome console by pressing CMD+SHIFT+J on Mac or CTRL+SHIFT+J on Windows and see if you have any errors in there and if you check what files are they referred to and try excluding those files from Autoptimize?

    Cheers,
    Predrag

    Thread Starter Rui Freitas

    (@rui-freitas)

    Hi Predrag.

    I am sorry, but I don’t know how to do it.
    I can’t see in Autoptimize-settings nothing like “file optimization” neither “one by one” option of anything.

    Is there any way I can send you the output of the console results?

    Thank you.
    Rui

    in Autoptimize on the main tab near the top-right corner you should see a button “show advanced settings”, click that and you’ll see extra fields, among which “Exclude scripts from Autoptimize”. There is more info on how to troubleshoot/ exclude from Autoptimization in the AO FAQ.

    hope this helps,
    frank (ao dev)

    Thread Starter Rui Freitas

    (@rui-freitas)

    Thank you Frank, but I am confused.

    What Predrag sayd was to disable file optimization one by one.

    In “Exclude scripts from Autoptimize” there are (naturally) excluded files.

    So, what should I do with this information? it seems to me contradictory.

    Thank you both.

    Rui

    well, what I would do is;
    * disable JS optimization and see if it works and if it does
    * enable JS optimization but disable JS aggregation and see if it works and if it does
    * enable JS optimization & aggregation but exclude hustle’s JS from JS optimization

    all the while keeping an eye on your browser console for JS errors off course.

    hope this clarifies,
    frank

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘Stoped working’ is closed to new replies.