Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Stop Jetpack resizing images?

  • Resolved jf80

    (@jf80)


    I’m using the Twenty Nineteen theme and when I try to add an image to a post, it gets resized.

    I add the image to the post.

    Then, in the editor window, I select the image and then choose Full Size from the Image Size drop down menu.

    The image is 1007 x 595 but Jetpack is resizing it to 640 x 378 which I don’t want!

    If I disable the Jetpack plugin, and then refresh the page, the image is displayed at full size.

    Any ideas how to stop this? Which setting is it in Jetpack?

    Many thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    That’s Jetpack’s image accelerator: https://jetpack.com/support/site-accelerator/

    In short, it’s serving the image size that matches the viewing device’s window size, so for example a mobile user doesn’t have to sacrifice data to load an original image that’s too big for their device anyway.

    Thread Starter jf80

    (@jf80)

    Thanks! I’m viewing it on a desktop with an HD resolution. Should it still be showing the smaller version of the image?

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    If it matches the size of your browser window, yes.

    What is the URL of the site with the problem?

    Thread Starter jf80

    (@jf80)

    It is this page:
    https://speedtester01b.host/hello-world/

    Thanks.

    Plugin Support fresatomica

    (@fresatomica)

    Thanks for the link. So can you let me know both your computer monitor and browser resolution?

    Also, if you wish, you can always disable the Image CDN (Speed up image load times) as explained here: https://jetpack.com/support/site-accelerator/

    Thread Starter jf80

    (@jf80)

    Thanks for your reply and sorry for my late reply!

    The computer monitor is 3200 x 1800 scaled to 200% in Windows 10 so is about 1600 x 900.

    Browser is maximized.

    Thanks

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    The image itself is being inserted as:

    <img src="https://i0.wp.com/speedtester01b.host/wp-content/uploads/2019/11/photodune-6252039-web-and-seo-analytics-concept-s-1.jpg?w=640&ssl=1" alt="" class="wp-image-16" srcset="https://i0.wp.com/speedtester01b.host/wp-content/uploads/2019/11/photodune-6252039-web-and-seo-analytics-concept-s-1.jpg?w=1007&ssl=1 1007w, https://i0.wp.com/speedtester01b.host/wp-content/uploads/2019/11/photodune-6252039-web-and-seo-analytics-concept-s-1.jpg?resize=300%2C177&ssl=1 300w, https://i0.wp.com/speedtester01b.host/wp-content/uploads/2019/11/photodune-6252039-web-and-seo-analytics-concept-s-1.jpg?resize=768%2C454&ssl=1 768w" sizes="(max-width: 640px) 100vw, 640px" width="640" height="378">

    There are a bunch of images in there now because that’s how WordPress’s responsive images work. It informs the browser that they’re all available, and the browser chooses the right size.

    In my case, I’m getting this image: https://i0.wp.com/speedtester01b.host/wp-content/uploads/2019/11/photodune-6252039-web-and-seo-analytics-concept-s-1.jpg?w=1007&ssl=1

    And, it loads as: https://cld.wthms.co/HIL8vD

    This is actually correct, because that’s the width of the theme’s content column: https://wp-themes.com/twentynineteen/

    What appears to be wrong here is actually the length of the caption, it should wrap below the image.

    This appears to just be how the theme operates, but there’s only one way to know. Does the image behave any differently if you deactivate the Jetpack plugin?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Stop Jetpack resizing images?’ is closed to new replies.