WordPress.org

Support

Support » Themes and Templates » Stop img from opening in a template page in 3.1

Stop img from opening in a template page in 3.1

  • In my custom theme img links by default opened in a lightbox.

    Since upgrading to 3.1 images in posts open in what looks like the single.php template file.

    Why? Is there any way to turn this new “feature” off?

Viewing 5 replies - 1 through 5 (of 5 total)
  • It’s not a new feature. I’m unsure why the behavior of your installation would have changed between WordPress versions 3.0 and 3.1.

    All I can suggest is: check the properties of each image (through the Media Manager, in the Edit Post screen), to ensure that it links to the image file rather than to the image post.

    The WordPress post editor now as default (?) adds a link to a template instead of the picture, like this:

    <a href="http://mysite.com/post/subject/image-2/" rel="attachment wp-att-130">

    It is easy to fix manually, but not helpful.

    Have you tried:

    – checking through Troubleshooting WordPress 3.1 – Master List

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    The WordPress post editor now as default (?) adds a link to a template instead of the picture

    But this change should not impact any existing images that have already been inserted into Posts.

    Are you sure you simply haven’t just checked “Post Url” instead of “File Url” under the Link when inserting images?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Stop img from opening in a template page in 3.1’ is closed to new replies.
Skip to toolbar