Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Stop email notifications for old posts being updtated

  • Resolved murielleb

    (@murielleb)


    Hello there.

    I’m doing some updating on my website, changing photos for the thumbnails, adding some bits and bobs on my old posts and for each update i make on old posts, an email is sent to my followers.
    As a result, last night about 100 emails were sent for each post I was updating.
    Which is annoying for the readers kind enough to follow me and embarrassing for me.`

    So… how to prevent or disable the emails notifications to be sent when it’s an old post being updated (not a new one being posted).
    A plugin, codex or something else to add to stop being annoying to my readers? Or do I have just have to disable the option notification on jetpack?

    I don’t dare updating my posts anymore in case a new wave of emails is sent.

    Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello murielleb, I replied in the another thread.
    Please add the below code to your functions.php file to add a checkbox option to every post of whether or not to email the post to subscribers.
    add_filter( 'jetpack_allow_per_post_subscriptions', '__return_true' );

    Let us know the results.

    Thread Starter murielleb

    (@murielleb)

    OK. So I have added the code to the functions.php file, but there’s no change on my wp. I have checked on several posts, no checkbox option on the page.
    The checkbox is present when I want to add a new article.

    My problem is for old articles already online which I update with thumbnail photos. A notification email is then sent to the subscribers as if it is a new post.

    I don’t know whether I’m clear.

    • This reply was modified 5 years, 4 months ago by murielleb.
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I’m sorry to hear you’ve run into issues. That definitely should not happen, as Jetpack Subscriptions should only be triggered the first time a post is published.

    Could you try to update to the most recent version of Jetpack, 4.3.1? We indeed solved a similar problem in that last Jetpack release.

    Let me know how it goes!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @lopwalj That filter won’t help, I’m afraid. It only adds a checkbox to the post editor, for posts that haven’t been published yet.

    Thread Starter murielleb

    (@murielleb)

    Hello. I have just updated jetpack and did a test with an old post, and it’s working !
    Thank you.

    Plugin Contributor Ryan C.

    (@ryancowles)

    I am glad to hear that the issue has been resolved! Please let us know if you experience any further trouble.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Stop email notifications for old posts being updtated’ is closed to new replies.