WordPress.org

Forums

WooCommerce
[resolved] Stop ! Do not upgrade with Woothemes MyStile v1.2.7 theme and WooCommerce 2.1.2 (2 posts)

  1. uscarsfrance
    Member
    Posted 2 years ago #

    Hi from France.
    I just encountered the issue and had to roll back to WooCommerce 2.0.20 and my yesterday last database backup. If you upgrade to WooCommerce 2.1.2 while your website is using Woothemes MyStile v.1.2.7, you will have the following fatal error :
    Fatal error: Call to undefined method WooCommerce::mfunc_wrapper() in [...]
    The error is related to this code line :
    49 > $woocommerce->mfunc_wrapper( 'woocommerce_cart_link()', 'woocommerce_cart_link', '' );
    I'm actually searching if the actual version of the MyStile theme available here :
    http://www.woothemes.com/products/mystile/
    ... has been updated for Woocommerce 2.1.2.
    Best regards.

    https://wordpress.org/plugins/woocommerce/

  2. uscarsfrance
    Member
    Posted 2 years ago #

    Hi. This specific issue is solved by installing Mystile v1.2.17 available from the Woothemes website. Best regards.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.