Support » Plugin: Mailchimp for WooCommerce » Stop customers auto-adding as Non-Subscribers to Mailchimp Contacts

  • Resolved siggifts


    Anyone that adds their e-mail at the checkout stage is then being automatically added to our Mailchimp contact list as non-subscribers. Our MC account is free meaning that we are nearly at our limit of contacts so I keep having to manually remove them. Is there a way of turning this function off?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support khungate


    @siggifts, thanks for reaching out. The transfer of contacts and ecommerce data over to your Mailchimp Audience is a core function of the plugin and can’t be turned off. If a customer unchecks the opt-in box at checkout they are passed over as unsubscribed; conversely, if the customer opts-in at checkout they are sent over as subscribed to the Audience.

    Are you seeing a different behavior as described?

    Plugin Author ryanhungate


    @siggifts we’ll go ahead and close this out for now since we haven’t heard from you in a few weeks – but if you would come back to complete the support debugging we’re here when you need us.


    @ryanhungate and @khungate, sorry have been very busy and unable to come back to you.

    At first I was getting anyone sign up if they ticked the box however I didn’t want this so this option was hidden. However as they are coming over as unsubscribed it still means I’m getting contacts, which keeps tipping me over my 2000 limit, meaning I have to keep removing these people as contacts. Is the only way around this to remove the integration?

    Plugin Support khungate


    Hi @siggifts, the core function of the plugin is to transfer all contacts from your store to Mailchimp. This allows you to take advantage of Mailchimp’s transactional, marketing and CRM features.

    At this time there is not a way to turn off this functionality per se, but you could manually delete any contacts that you don’t want from time to time in Mailchimp.

    Hi @khungate

    Ah right ok, not to worry then, thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.