Support » Plugin: Subscribe2 » Stop auto redirect from widget

  • Resolved Peter Gordon



    Love the plugin – Many thanks.

    Just one quick question. How do I stop the automatic redirect to the subscribe2 default page when a submission is made through the widget.

    (I have tried removing the form action parameter within the plugin core and it seems to work, but I’m assuming this is not a proper or good approach.)

    Thanks in advance

Viewing 6 replies - 1 through 6 (of 6 total)
  • @peter,

    You could set Homepage as the redirect page in the Widget settings (on the Appearance -> Widgets page).

    Hi, thanks for the reply.

    But I don’t want to send people to any page. I’d like the widget to not redirect at all upon submission. a returned message appearing under the widget is sufficient.

    Would it be a case of me coming up with something that extends the front-end form part of the widget, if I didn’t want to touch the plugin code?




    Your response made me go away and check the code just to be sure. If you use the “Use Homepage” setting in the Widget it actually leaves the ‘action’ parameter of the form empty and should therefore leave the user on the current page. Give it a try and if it works it means no coding needed 🙂

    Ahhh, makes sense… I think this is where I started to think about this issue. If I’m not mistaken, if the action parameter is empty it would lead to a html validation error?


    That would be invalid code in HTML5 but not XHTML. I guess I need to work on that bit of the code for the next version.

    That would be great.

    I’ve ordered the pro and I’m looking forward to getting it set up.

    Many thanks for your help and time. I



Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Stop auto redirect from widget’ is closed to new replies.