Support » Plugin: Booking Activities » stock available is not hidden on website

  • Hello,
    I ask this here because this is happening since we have update new versión of Booking activities.

    Before we have hidden the stock on the products. We don´t want to show the real availability to the clients to get urgency. So we only show when there are less than 2.

    Since we have update booking activities the real stock is showing and it´s not taking the information done in setting woocommmerce.

    Is there any related or anything?

    Thank you very much.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter vanesa2022

    (@vanesa2022)

    HELLO,

    The forum WOOCOMMERCE has given to me this information. The issue is coming from the plugin booking activities. Can you please help me?

    Hi @vanesa2022,

    Thank you for the screenshots. They’re helpful.

    Inspecting your product page I can see the stock quantity comes from your Booking Activities plugin:

    Full Size: https://i.imgur.com/3Do0H1a.png

    This plugin is overriding the default WooCommerce core function which is supposed to show the quantity remaining in stock only when equal to or lower than 2 as per the low stock threshold in your product inventory settings.

    Please note that this forum is specific for the WooCommerce core plugin. Since the problem is related to the Booking Activities plugin, the issue would be best handled in their support forum:

    https://wordpress.org/support/plugin/booking-activities/

    Feel free to share a link to this thread on the plugin support page, so the information will be available to the support staff.

    Best regards.

    Plugin Author yoancutillas

    (@yoancutillas)

    Hello,

    Indeed, you should not use WC’s stock for products bound to a Booking Activities’ booking form. The availability is handled by Booking Activities (WooCommerce stock would be reduced overall, regardless of the booking date). Can you remove the product stock in the Product data?

    Then, in order to hide the events availability, go to Booking Activities > Booking forms > your form > Calendar settings > Display tab > “Hide availability if greater than” = 0% > OK.

    Thread Starter vanesa2022

    (@vanesa2022)

    Hello,

    I have tried and it´s not working. Something has changed suddenly since a couple of weeks ago. Before was perfect, was showing number when was less than 2 and nothing more than 2 generating urgency to the customer. Now is showing in all cases.

    In the other hand we have a system who is sending us email when we have inventory less than 2, this way we can add new sessions. We cannot delete the inventory or product stock in the product data…

    What you propose is to go one by one to all the booking forms hiding availability?

    I need to be something we can do because before was ok.

    Can you please check other option?

    Thank you

    Plugin Author yoancutillas

    (@yoancutillas)

    I can see on your site that you have only one event on each form.
    That is why it looked like it was working for a time,
    but I, the plugin author, and WooCommerce support can confirm: WC product stocks are not to be used with Booking Activities events availability.

    In order to hide the events availability, you need to do the following for each booking form:
    go to Booking Activities > Booking forms > your form > Calendar settings > Display tab > “Hide availability if greater than” = 14% > OK

    (If you want to display the number of available places only when 2 or less remains, and if the events availability is “15”, then you need to set the “Hide availability if greater than” option to 14%, because 14% of 15 places ≃ 2 places)

    Thread Starter vanesa2022

    (@vanesa2022)

    Hello,

    Thank you for your reply. We are still on this. I did what you say but dissapear the number when is more than 14% but not the word PLAZAS.

    look this product
    https://la-patente.es/product/cocina-de-vanguardia/
    One session is 1 plaza, other plaza.

    Where the word plaza is coming from?

    Do you think that this is because i have updated Booking Activites? before, everything was working correctly.

    Thank you for your help on this

    Thread Starter vanesa2022

    (@vanesa2022)

    Hello,

    It´s not working. On the main calendar is showing the number…. even i hide availability. Check

    https://la-patente.es/calendario-de-proximas-actividades/

    I need a profesional to help with this and fix it please. This was working perfectly before, now it is a mess. Can someone help going into the wordpress application and check please?

    Thank you

    Plugin Author yoancutillas

    (@yoancutillas)

    You can remove the word “plaza/s” with custom CSS in Appearence > Customize > Additional CSS
    .bookacti-availability-container.bookacti-hide-availability { display: none !important; }

    “Plaza/s” is probably the translation for “avail.” into your language (see the demo website).
    You can create your own translation by following the instructions below “Translate Booking Activities into my language” here: https://booking-activities.fr/en/documentation/faq/

    The calendar on that page is currently set to display availability numbers. If you want to hide the availability numbers, go to Booking Activities > Booking forms > your form (form #4) > Calendar settings > Display tab > set “Hide availability if greater than” to 0% > OK

    In order to hire a web developer / agency, contact them directly.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.