Support » Plugin: Easy Updates Manager » Still: Your site may have problems auto-updating plugins and themes

  • Resolved hommealone

    (@hommealone)


    Under “Site Health” the notice still appears when your terrific plugin is installed. In the plugins list, it says they are handled by your plugin, but the Site Health critical notice is still appearing.

    You marked a few threads about this as resolved, but the issue still exists. I know that it is due to WordPress core changes regarding updates, and possible issues with the way that was set up. Just wondering if there is any news on when this might be resolved?

    Right now, I’d appreciate an explanation and update on the issue, even if there is no way to resolve it yet.

    Thanks!

    • This topic was modified 5 months, 1 week ago by hommealone.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support bcrodua

    (@bcrodua)

    Hi,

    Do you have caching plugins? Can you try clearing cache and see if the message disappear?

    Thanks,
    Bryle

    Thread Starter hommealone

    (@hommealone)

    Thanks for your reply! Yes we do use caching.

    I just tried your test, with no luck.

    I cleared the cache. I immediately revisited the Site Health page, and the “Critical Issue” remains.

    Your site may have problems auto-updating plugins and themes.

    If I disable the plugin, The Critical Issue goes away.

    Perhaps related…
    On some of my sites there is also a Site Health “Recommended Improvement”:
    “Background updates may not be working properly”
    “The folder [root folder of the domain] was detected as being under version control ( .git ).”

    This message does NOT go away when I disable the Easy Updates Manager plugin.

    But note also: on other sites without .git, I get the same Critical Error with Easy Updates Manager enabled, and the Critical Error goes away when it is disabled – and there is never that same “Recommended Improvement” notice since those sites do not use .git at all.

    I believe that the git setup is part of the hosting provider’s Managed WordPress package.

    (Normally, with the plugin active, updates do take place as expected based on the settings in the plugin.)

    Thread Starter hommealone

    (@hommealone)

    More suggestions please?

    Clearing the cache does not solve the problem. I still have the “Site Health” Critical Error. This occurs on sites that are under .git control, and also on sites that are not.

    Furthermore, I see the Site Health page when I am logged in, obviously, and the site does NOT cache content for logged-in admins.

    Disabling the Easy Updates Manager plugin immediately removes the “Site Health” Critical Error.

    What other troubleshooting steps can I try to resolve this issue?

    The caching plugin in use on some of my sites allows me to exclude specific URLs from caching, and to exclude specific “Cookies which, if present, will prevent caching”. Is there a URL or cookie that I could try to exclude in order to solve this?

    Please, this problem has been going on for a long time!

    Plugin Author David Anderson

    (@davidanderson)

    Is there something leading you to think that this problem is related to Easy Updates Manager? Ultimately, EUM just provides a way to answer “yes” instead of the default “no” when WordPress internally runs its “shall I auto-update this plugin?” checks. It doesn’t itself perform the updates. As such, there isn’t anything inside EUM you can tweak to fix it; the problem is in your WP install itself. It’s most likely to be your file permissions; as such, you should speak to your web hosting company to see how things ought to be on their setup to make it work.

    Thread Starter hommealone

    (@hommealone)

    Thanks @davidanderson for helping me puzzle this out!

    Your help with troubleshooting is appreciated! I’m asking you about this because the error message is displayed when your plugin is enabled, and not displayed when it is disabled. I’m just trying to understand…

    Why would I only get the Critical Error message when I have your plugin enabled, and not get the same Critical Error message when I disable it? Any idea what your plugin is telling WordPress which would cause WP to display that message, when it otherwise would not?

    I have the plugin installed on many different websites, in many different server setups, using different hosting companies in some cases. In all cases: I only get the error message when your plugin is enabled. File permissions, which you asked about, are as recommended: directories 0755; files 0644.

    What other troubleshooting steps might I take? What else might be going on?

    Thanks again for any suggestions!

    Plugin Author David Anderson

    (@davidanderson)

    > Why would I only get the Critical Error message when I have your plugin enabled, and not get the same Critical Error message when I disable it?

    Because by default, WordPress’s code for running background plugin updates goes unused. It is only used if you use something to turn it on – such as Easy Updates Manager (or, since WP 5.5, WP’s built-in auto-updates on the ‘Plugins’ page).

    What file ownerships and permissions are correct for a setup is web-hosting company-dependent. Therefore, you should ask your web hosting company what needs to be done to have them working on your site.

    David

    Thread Starter hommealone

    (@hommealone)

    This problem still persists. As noted, the file permissions are the same, and across multiple hosting companies and different hosting set-ups. That would seem to rule out a file permissions problem (right?)

    Any other suggestions about how I might go about troubleshooting this would be much appreciated!! I understand that you believe this is not caused by your plugin, and that might well be correct. But your plugin is the one that I use for controlling updates, and WordPress updates is your area of special expertise, so since my Site Health error message is “Your site may have problems auto-updating plugins and themes.” I’m hoping that you might be able to help me with my further troubleshooting.

    BTW, my Easy Updates Manager settings are set to:
    Core updates: “Auto update all minor versions”
    Plugin updates: “Choose per plugin” (with two plugins set NOT to update automatically)

    Those settings in themselves wouldn’t necessarily cause the Site Health error message, right? Or would they?

    Has this been resolved?

    The Site Health issue seems to appear whenever EUM is set to ‘Choose per plugin’ and/or ‘Choose per theme’.
    When EUM is set to ‘Enable auto-updates’ the issue is gone.

    However, when in addition, I use the ‘Health Check & Troubleshooting’-plugin, is seems to be resolved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.