Support » Plugin: WP-SpamShield » Still showing status: install not correctly

  • I read the guides, changed permission, added code to wp-config but still no luck. Seem this plugin can not work with nginx.

    But I am curious what that status mean? The plugin will change our files or modify something on WP?

    Learn from Akismet please.

Viewing 1 replies (of 1 total)
  • Plugin Contributor Red Sand Media Group

    (@redsand)

    Hi Tien Nguyen,

    This negative review is undeserved. You really need to read the plugin documentation.

    This should be a support request, not a review.

    It is clearly stated in the plugin’s Minimum Requirements that standalone Nginx servers do not meet the plugin’s minimum requirements.

    Your server must be configured to allow the use of an .htaccess file. The vast majority of users will have no issue here, because most web hosts allow this by default. However, if yours does not, you will need to contact them and ask them to enable it on your site. If they won’t, then it’s time to get a better web host. WordPress loses a lot of functionality if you don’t have use of .htaccess enabled, so this is important for full functionality of WordPress and other plugins as well.) Note: By definition, a standalone Nginx server would not meet this requirement, but an Apache/Nginx hybrid setup would. (Nginx is setup as a reverse-proxy in front of Apache. This type of setup offers high-performance and is recommended.)

    I really am sorry to hear that you had an issue.

    However, I have to ask, why would you post a negative review without even submitting a support request first?

    We really do offer outstanding support. You should give us a chance to help you.

    It is important for all plugin users to read the documentation. We ask users to take a few minutes to work through the Troubleshooting Guide and FAQs completely, as these solve over 90% of issues users have. If you need further help, then we are happy to provide support.

    You mentioned that:

    I read the guides, changed permission, added code to wp-config but still no luck.

    It looks like you skipped a few key steps.

    Troubleshooting Guide Step 2: “Check the Known Issues and Plugin Conflicts.” On the Known Conflicts page, there is a section on standalone Nginx servers.

    Troubleshooting Guide Step 7: “Check to make sure the plugin is installed properly.” In this step, it specifically says to check the minimum requirements:

    Many support requests for this plugin originate from improper installation and can be easily prevented. To check proper installation status, go to the WP-SpamShield page in your Admin. It’s a submenu link on the Plugins page. Go to the ‘Installation Status’ area near the top and it will tell you if the plugin is installed correctly. If it tells you that the plugin is not installed correctly, please double-check what directory you have installed WP-SpamShield in, delete any WP-SpamShield files you have uploaded to your server, re-read the Installation Instructions, and start the Installation process over from step 1. Also, be sure you meet the plugin’s minimum requirements. (Located on the bottom of the main documentation page.)

    Please ask yourself this…When developers spend so much time developing free plugins for the WordPress community, is it really ok to post a 1-star review without making any reasonable effort to receive support? That’s simply not the right way to handle things.

    If you have an issue with something, submit a support request first, and give the author time to respond. We provide free support for our plugins…all you have to do is submit a support request at the WP-SpamShield Support Page. We provide some of the best support out there.

    You might want to take a moment to check out these two posts:

    I would ask that you reconsider your rating, as it simply isn’t accurate or fair. It can be updated by going to: https://wordpress.org/support/view/plugin-reviews/wp-spamshield#postform

    Reviews like this simply do not help the global WordPress community.

    – Scott

Viewing 1 replies (of 1 total)
  • The topic ‘Still showing status: install not correctly’ is closed to new replies.