Support » Plugin: Customize WordPress Emails and Alerts - Better Notifications for WP » Still sending WP notifications too

  • Resolved bluedot

    (@bluedot)


    We installed your plugin, and have found that even with the added notification, the standard WP notification is still being sent too, for a total of 2 emails to the post author.

    I use Mandrill (from Mailchimp) for our transactional SMTP server.

    This one sends correctly, per your login:
    wp_BNFW_Engine->send_notification

    However it is also sending this one too, which is the standard notification.
    wp_wp_notify_postauthor

    It seems like the plugin is not turning off the original hook? Do you have any recommendations for troubleshooting this?

    We are using WPDiscuz

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author bnfw

    (@voltronik)

    Hi @bluedot,
    Thanks for your message.

    Are you using code from this page per chance? https://gist.github.com/mariusvetrici/44acdacd6b283ccd46d9

    I ask because it’s the only reference to that function I can find online. The core function only has one wp_ (wp_notify_postauthor), where the code in the above link has two wp_’s (wp_wp_notify_postauthor).

    It’s may be worth running through this help document to help track down any potential issues and/or conflicts too: https://betternotificationsforwp.com/how-can-i-receive-the-best-support/

    trylobyte

    (@trylobyte)

    I have the same problem. The new notification is sending to the designated user but it also sends the standard WP notification to the post author and I don’t want that. I have tried deleting the cache after disabling the notification on the top right option and saving, with no luck.

    I am using the WP standard comments system (WordPress 5.4.4).

    Thanks.

    bluedot

    (@bluedot)

    Thanks for your response – but no, I’m just using Mandrill’s plugin, and sending them to their transactional template. However, I run a very custom membership community site (buddypress) that uses 89 plugins to operate and 1100 lines of functions.php

    Luckily I work with a development server too!

    I am in the midst of switching everything to Sendgrid, I’ll do a test today to see if that may be where the problem is, and report back. It could be an easy fix if so.

    However – it sounds like @trylobyte here is having the same issues without Mandrill?

    • This reply was modified 2 months ago by bluedot.
    bluedot

    (@bluedot)

    In the process of troubleshooting this, I removed our Mandrill SMTP, added the WP Mail SMTP plugin and setup our Sendgrid API.

    We are using a custom post type “Reports” in your plugin. However, both the plugins notification and the original WP notification are both sending to the post author when a comment notification is sent.

    More troubleshooting soon.

    Well, what a wonderful day was spent troubleshooting this. I wish I could say I found the issue – but it was ours, somehow, in our custom post type “Reports” – not in any other custom post type. With all plugins disabled. With functions.php turned off by using the 2015 theme. It worked fine in a standard install on another domain. Crazy!

    However, I did solve it by turning off the notification email in the discussion settings. It seems your plugin still sends the notifications if this is turned off, thank goodness. It removed the duplicate!?

    Plugin Author bnfw

    (@voltronik)

    Hi @bluedot,
    Not a problem at all. When things are complex, in can take a while to find the issue but glad you’ve found it and it’s all now working for you.

    If you like BNFW and the support, please feel free to leave an honest review.

    • This reply was modified 1 month, 4 weeks ago by bnfw.

    Thanks, @bluedot, disabling the standard email notification from the WP Comments settings also solved my issue with the duplicated notification email. Now I receive only the notification email from BNFW. The custom notification in the plugin is enabled.

    (I think the tooltip help at the right of the radio button “Enable Notification” can be a bit confusing. As it says “Use this to enable or disable notifications. If you want to disable a default WordPress notification, just create it on the left, then disable it here.” However, in my case, I had to keep enabled the custom notification in the plugin and disable the standard notification on the WP comments settings.

    Thanks also @voltronik for this great plugin.

    Plugin Author bnfw

    (@voltronik)

    Hi @trylobyte,
    Thanks.

    This is true for all notifications except for the Comment notifications. This is mentioned in the documentation for the plugin but I agree, it’s not obvious in general. I haven’t found a work around as yet but hoping to one day!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.