Support » Fixing WordPress » Still seeing Notice:undefined index…with debug off

  • I have turned off debugging in wp_config but am still seeing

    Notice: Undefined index: google_map_key in /var/www/vhosts/ on line 43

    type messages when I try and run different plugins. Both of these plugins are event management ones and I really need them to work asap for a client. Actually, they do work, but only if you navigate around all the error messages.

    Is there another way to stop the error messages? I have googled and searched these forums for days and I can’t come up with a solution. I contacted the plugin writers and they just told me to turn off debugging, which I have already done.

    I am running 3.2.1 using a child theme in twenty eleven. I don’t have this problem with any other plugin and I have tried deactivating the others to no avail.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Generally that warning means that the plugin is trying to do something with a variable or array key that doesn’t exist. For example, this could mean it’s trying to do something with some option that maybe you haven’t set, but the plugin isn’t correctly setup to check for that… So, maybe if you made sure whatever missing option does actually exist, you could get the warning to go away.

    So to do this, try going to this wourdtour plugin’s setting page, finding what could be named similar to a “Google Map Key” option, and fill it in.

    Thanks. That was what I assumed and have been going through and trying to put in data to give the variables a value but with limited success. I believe it is an issue with both plugins (WorldTour and GigPress) but I don’t know enough php to fix the code.

    Lots of people are using them with seemingly no issue so I was wondering if 3.2.1 has a more intense debug feature or something?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Still seeing Notice:undefined index…with debug off’ is closed to new replies.