Support » Plugin: Disable Gutenberg » Still seeing Gutenberg on Posts & Pages

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Are you using any cache plugins?

    No caching plugins. I use Cloudflare, but I’ve cleared that cache and even tried disabling it temporarily. Still seeing it. I also checked other sites that I manage and I’m seeing the same on all of them. I think it may have been working before the last plugin update, if that helps.

    Plugin Author Jeff Starr

    (@specialk)

    I just re-tested on WP 5.1 and everything is working normally. Here is a video of DG on WP 5.1 (small zipped movie file), showing creation of a new post and page normally with the classic editor. So not sure what might be interfering in any particular case, but there are a few general things you can check:

    • Running latest WP
    • Running latest DG
    • Not running any other “disable gutenberg/classic editor”-type plugins
    • Check any cache plugins
    • Clear your browser cache and cookies
    • Troubleshoot plugins and theme

    I hope that helps, let me know if I can provide any further infos.

    I’m running the latest WP on all of the sites I checked. I turned off the caching, deleted DG, reinstalled and activated it and am still seeing Gutenberg Editor as an option in the Pages and Posts main list when I hover over a post or page. The default editor when I click “Edit” or on the title of the page/post goes to Classic, so the Gutenberg editor is not a nuisance the way it was previously, but it still shows up.

    I looked at your video and took a look at the behavior of DG on a site that doesn’t use the same theme as the others and it looks like it’s working there. So, my guess is that it’s a conflict with the theme I’m using on these other sites. The theme (Avada) has its own built-in page builder, which *really* didn’t play nice with Gutenberg and was the reason for wanting to turn that off. But I think it is perhaps be the reason parts of the DG plugin aren’t working the way they’re intended.

    One would probably have to dig into how both page builders integrate or hook into the WP code in order to troubleshoot where the conflict is. For what it’s worth, the Avada theme is a #1 bestselling theme used by a lot of people, so it’s probably at least worth noting the conflict.

    Plugin Author Jeff Starr

    (@specialk)

    Yes it sounds like a theme-related issue, as shown in the video latest DG version is working fine. I will check out Avada theme if possible and see if there is anything that can be done on DG side of things. I definitely want the plugin to compatible with such a popular #1 bestselling theme.

    Plugin Author Jeff Starr

    (@specialk)

    Interesting, because it is working fine for me (video taken moments ago):

    Video of Disable Gutenberg working fine with WP 5.1 (~4MB zipped movie file)

    Same setup: Twenty Nineteen theme, latest DG plugin, latest WP. No issues.

    • This reply was modified 10 months, 2 weeks ago by Jeff Starr.
    Plugin Author Jeff Starr

    (@specialk)

    From my tests, DG works fine for any post type, including pages. See the first of my two videos I think shows Pages working normally with DG.

    Plugin Author Jeff Starr

    (@specialk)

    It may not be compatible with Avada theme, I am not sure.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Still seeing Gutenberg on Posts & Pages’ is closed to new replies.