WordPress.org

Support

Support » Plugins and Hacks » WordPress MU Domain Mapping » Still not working… How to redirect non-www to www on mapped domains?

Still not working… How to redirect non-www to www on mapped domains?

  • This has been addressed in other threads here, but the solutions are not working for me.

    Let me explain my setup more clearly:

    I have a multisite network built around maindomain.com. I have clients websites on my network, which initially get client1site.maindomain.com, client2site.maindomain.com, etc. I then use domain mapping to map the client’s own domains to the sites.

    I’m using CNAMES and not A Records (IP address) to point clients domains. The reason is, I don’t want clients to be tied to my servers IP address, just in case I ever decide to move servers I don’t have to ask every client to change their A Record setting.

    Here is what I’m doing for each client’s domain mapping:

    Add client1site.com as a Parked Domain in my cpanel.

    Set a CNAME at the client’s registrar, pointing http://www.client1.com to client1site.maindomain.com

    In Network Admin > Domains, I add the following two entries:

    Site ID 34 (whatever the clients site ID is)
    http://www.client1site.com
    Primary: Yes

    Site ID 34 (whatever the clients site ID is)
    client1site.com
    Primary: No

    Now how do I ensure that client1site.com redirects to http://www.client1site.com?

    I have tried setting up a “Forward” at the clients registrar. Most of the time, this just doesn’t work (every registrar is different).

    I have tried adding the redirect code to my main site htaccess (as described in this thread) but that doesn’t affect the mapped domain at all.

    Please help 🙂

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

Viewing 3 replies - 1 through 3 (of 3 total)
  • by the way – this forum added http:// to those www urls. Not me.

    Plugin Author Ron Rennick

    @wpmuguru

    MultiSite Guru

    If the solution in the thread you linked to did not work then you may have added the code to the wrong location in your htaccess. Another possible issue is that rewrites are not enabled for that vhost.

    Thanks Ron,

    I tried placing the code from that solution in every possible position in the htaccess file, nothing worked.

    Question 1: So the htaccess in the root level of the multisite installation does in fact affect redirects for mapped domains on the network (not just the main domain). Yes? (I wasn’t sure…)

    Question 2: “rewrites not enabled for that vhost”… can you clarify? I have a managed VPS hosting. Should I contact them and ask them to enable redirects? Is there another way to check whether or not they are enabled?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Still not working… How to redirect non-www to www on mapped domains?’ is closed to new replies.
Skip to toolbar