Support » Plugin: Genesis Connect for WooCommerce » still no content

  • Resolved rad-design

    (@rad-design)


    Found the Genesis Connect plugin after installing and setting up the Woocommerce product pages, then realizing the pages were not formatted correctly. I installed the connect plugin and added the code to my functions.php. The product pages worked perfectly! But, checking all the other pages (including the shopping cart) I found there was no content. I have seen other posts regarding this issue, but nothing I have tried works. I can deactivate the plugin and the content returns immediately.

    Genesis v. 2.1.2
    Beautiful Pro v. 1.1
    Woocommerce v. 2.4.4
    Genesis Connect v. 0.9.8
    http://www.mamasaysnamaste.com/

    Any help would be greatly appreciated!

    https://wordpress.org/plugins/genesis-connect-woocommerce/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Note: plugin is currently deactivated since this is a working blog site

    Plugin Contributor Nick Cernis

    (@modernnerd)

    Hi, rad-design!

    Missing page content appears to be a result of activating Genesis Connect before WooCommerce pages have been created. It may be worth recreating the WooCommerce pages to see if that solves things for you:

    1. Deactivate Genesis Connect and activate WooCommerce.
    2. Delete the WooCommerce Cart, Checkout, My Account and Shop pages from the Pages → All Pages area. Be sure to empty the trash.
    3. Go to WooCommerce → System Status, and click the “Tools” tab.
    4. Click the “Install pages” button about half way down the Tools tab.
    5. Confirm that the WooCommerce pages have been recreated.
    6. Activate Genesis Connect again.

    Feel free to report back if you have a chance to try this; it seems to solve things in my local test install.

    Nick, thanks so much! That did it. Not exactly sure why it did it, but it did. I did not use Woocommerce -> System Status -> Tools previously to create the pages. I added them manually and used the shortcodes.

    You mentioned the issue appeared to be due to the pages being created before activating the Genesis Connect plugin. However, all of my pages were created before I found the plugin.

    Oh well, it is working and my client will be happy

    Thanks again!

    Plugin Contributor Nick Cernis

    (@modernnerd)

    You’re welcome, rad-design! Glad that fixed things for you, and sorry for the trouble.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘still no content’ is closed to new replies.