Support » Plugin: WebP Express » Still no Auto Option

  • Resolved satoshibits

    (@satoshibits)


    Installed webp express.
    >Configuration – found no auto option even with imagick operational
    >Went to Cpanel > switched to gmagick
    >Gmagick operational – still no auto option

    Why is that? Did I miss any step?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author rosell.dk

    (@roselldk)

    Yeah, that doesn’t sound right.

    When you say that Imagick / Gmagick are operational, I take it that you see the green checkmark on these rows in the options page, right?

    Plugin Author rosell.dk

    (@roselldk)

    As for Imagick:

    The Imagick extension should be able to detect quality PECL >= 2.2.0.
    The problem *could* be that you are on an older version.
    Can you check your PECL version for me?

    version-check.php:

    <?php
    echo 'Imagick PECL version:' . phpversion("imagick");
    echo 'Imagick version:' . print_r(\Imagick::getVersion(), true);
    ?>

    As for Gmagick:

    Gmagick extension actually doesn’t support detecting image quality: https://bugs.php.net/bug.php?id=63939

    However, WebP Express does try to use gmagick for detecting quality, by executing gmagick with exec(). Exec calls are probably not allowed on your server.

    I shall update the help texts…

    • This reply was modified 10 months, 2 weeks ago by  rosell.dk.
    Plugin Author rosell.dk

    (@roselldk)

    The “auto” option is available, when WebP Express detects that it can detect the quality of a test-image.

    But actually, it is possible to have “auto” quality with imagick extension, without being able to detect the quality: If no quality is set, imagick will detect quality of source and use that.

    So – I could do something to allow auto quality with imagick, even when quality detection is unavailable. I shall make it possible to override the quality option for imagick, allowing it to be set to “auto”. I already have such functionality for the Remote WebP Express conversion method.

    Sorry for the delayed reply.

    >Yes , I see the green marks.

    >Sorry I have no knowledge with PHP whatsoever, some instructions on how to check for PECL version? My web host is Hostinger, if that helps.

    Plugin Author rosell.dk

    (@roselldk)

    To check pecl version do this:

    1: Create a file “versioncheck.php” in the root folder with the following content:

    <?php
    echo 'Imagick PECL version:' . phpversion("imagick");
    echo 'Imagick version:' . print_r(\Imagick::getVersion(), true);
    ?>

    2: Point your browser to the php. Ie: http://example.com/versioncheck.php

    Here you go:

    Imagick PECL version:3.4.3RC4Imagick version:Array ( [versionNumber] => 1684 [versionString] => ImageMagick 6.9.4-10 Q16 x86_64 2017-05-23 http://www.imagemagick.org )

    Plugin Author rosell.dk

    (@roselldk)

    Thanks!

    This probably means I have a bug to fix.

    However, in the upcoming version of WebP Express, I have implemented that you can override the general quality option and set it to “auto” for imagick. So you don’t have to wait for the bug to be resolved. I’m releasing v 0.8 today or tomorrow.

    Thanks. Cheers !

    Plugin Author rosell.dk

    (@roselldk)

    0.8.0 is out, and you should now see the auto option, when you click “configure” on the imagick conversion method!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Still no Auto Option’ is closed to new replies.