Support » Theme: Pilot Fish » Still looking for a way to make Pilot Fish navigation work in IE 8

  • Resolved Jana

    (@janajanasnydercom)


    I’ve fixed all the issues I was having with IE 8 compatibility except for the main menu/nav stacking instead of displaying horizontally. This also messes up the main image on the home page, if you have something that matters how it’s framed up (which I do).

    (And clicking IE’s “compatibility view” makes the entire home page fall apart completely!)

    I wouldn’t mind missing out on the background/bar image in the nav, if the whole thing would just go horizontal instead of vertical.

    Anyone have a fix for this? Author: any chance you might write a fix for it?

    Here’s my site (on test server): http://s001.janasnyder.com/~blackbea/

    Thanks.

Viewing 15 replies - 16 through 30 (of 41 total)
  • Jana

    (@janajanasnydercom)

    Thank you! I understand that.

    Thank you for being so helpful. And for the lovely theme. 🙂

    Jana

    (@janajanasnydercom)

    I did that one hour ago. (ftp’d the new script to the includes folder and made sure the other one is in the js folder.)

    Still not working. :/

    Theme Author Daniel Zhao

    (@danni1990)

    Hi Jana,

    I just checked your site, and you have imported the css-mediaqueries javascript twice. Could you remove the one you added a while ago (here) and try again?

    Jana

    (@janajanasnydercom)

    Okay, I just now:
    – removed css-mediaqueries.js from js folder
    – ftp’d css-mediaqueries.js (making sure not to get the one w/ (1) in the file name) into the js folder again

    Still no effect.

    Theme Author Daniel Zhao

    (@danni1990)

    and did you remove the line<script src="http://s001.janasnyder.com/~blackbea/wp-content/themes/pilot-fish/js/css3-mediaqueries.js"></script> from your header.php file?

    Jana

    (@janajanasnydercom)

    Yes. No change. Put it back in. No change. Repeated. No change.

    Theme Author Daniel Zhao

    (@danni1990)

    But I just checked your site and under the firebug, the script still imported twice, and before the CSS stylesheet. Could it be that you enabled the Cache on your website?

    Jana

    (@janajanasnydercom)

    I have not enabled cache, and I have not added any plug ins.

    I see what you mean in firebug, but it only appears once in header.php

    Here is where the script is; have I put it in the wrong place?

    <title><?php wp_title(); ?></title>
    <script>window.jQuery || document.write('<script src="http://code.jquery.com/jquery-1.7.2.min.js"><\/script>')</script>
    <script src="http://blackbearbosin.com/wp-content/themes/pilot-fish/js/css3-mediaqueries.js"></script>
    <?php pilotfish_head(); // head hook ?>
    <?php wp_head(); ?>
    <meta http-equiv=”X-UA-Compatible” content=”IE=EmulateIE7? />
    </head>
    Theme Author Daniel Zhao

    (@danni1990)

    oh, remove this the link to the javascript from header.php file.

    It is linked in scripts.php file already.

    Jana

    (@janajanasnydercom)

    Okay, I’ve removed it from header.php. Now it looks like this:

    <title><?php wp_title(); ?></title>
    <script>window.jQuery || document.write('<script src="http://code.jquery.com/jquery-1.7.2.min.js"><\/script>')</script>
    <?php pilotfish_head(); // head hook ?>
    <?php wp_head(); ?>
    <meta http-equiv=”X-UA-Compatible” content=”IE=EmulateIE7? />
    </head>

    Still not working.

    Theme Author Daniel Zhao

    (@danni1990)

    Are you using page menu? Or Custom menu?

    Jana

    (@janajanasnydercom)

    page menu.

    Theme Author Daniel Zhao

    (@danni1990)

    Could you switch to custom menu? Because I’m using custom menu, maybe that’s the difference…

    Jana

    (@janajanasnydercom)

    Sorry; my mistake. I am using custom menu.

    Theme Author Daniel Zhao

    (@danni1990)

    In the style.css, find this part:

    /* Primary Navigation */
    /* Style Primary Navigation Specific to viewport width */
    @media (min-width: 481px) {
    	#access .menu {
    		clear:both;
    		margin:0 20px;
    	}

    and add “screen and” after @media, so it will be like this:

    /* Primary Navigation */
    /* Style Primary Navigation Specific to viewport width */
    @media screen and (min-width: 481px) {
    	#access .menu {
    		clear:both;
    		margin:0 20px;
    	}

    hope this works~

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘Still looking for a way to make Pilot Fish navigation work in IE 8’ is closed to new replies.