Support » Plugin: ReCaptcha v2 for Contact Form 7 » Still loading V3.

  • Resolved basvandijkk

    (@basvandijkk)


    The V3 of the Google API is being loaded while having selected the V2 version. I’ve used this plugin on multiple websites before without having ever had any problems.

    When visiting my url the credentials for alert are:
    username: web
    password: whales

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author IQComputing

    (@iqcomputing)

    Hello,

    Thanks for bringing this to our attention! It looks like that we are using some jQuery without expressing it as a requirement. This should be fixed in the latest update which just released. In the future we’ll look at decoupling this and converting the jQuery block to vanilla Javascript to remove the requirement entirely.

    If the latest update doesn’t fix your issue please reply back to this thread and we can look into this further. We’ll mark this thread as resolved for now. Have a wonderful rest of your week!

    Thread Starter basvandijkk

    (@basvandijkk)

    @iqcomputing Hi, thanks for your response. It’s still not really working. I also saw in one of the other tickets that you guys were implementing the choice to use recaptcha.net. I’ve also tried to use this option but the 3.0 version is still being loaded.

    It looks like the action that loads the 3.0 version is not being removed.

    https://ibb.co/m5Ddm7Q

    Thread Starter basvandijkk

    (@basvandijkk)

    @iqcomputing It’s still not working. Can you give me an update about this problem?

    Plugin Author IQComputing

    (@iqcomputing)

    Hello,

    Looking at the source is appears that the site is still loading v=3.0 which could mean that the plugin hasn’t been specified to use version 2.0. See the linked image below:

    https://ps.w.org/wpcf7-recaptcha/assets/screenshot-1.jpg

    Additionally, there’s a console error that jQuery is not defined which should be loaded before the reCaptcha script. Maybe make sure the theme has both wp_head() and wp_footer() functions in the expected places. If you’ve updated to the latest version (v1.1.9) of this plugin it specifies jQuery as a requirement:

    wp_register_script( 'google-recaptcha', $url, array( 'jquery' ), '2.0', true );

    We’ve also tested this using the most basic/bare custom theme to ensure this works as expected.

    Regarding your linked image, using the setup_theme hook our plugin removes the contact form 7 hook and replaces it with our own:

    remove_action( 'wp_enqueue_scripts', 'wpcf7_recaptcha_enqueue_scripts', 10 );
    add_action( 'wp_enqueue_scripts', 'iqfix_wpcf7_recaptcha_enqueue_scripts', 10 );

    – – – – – – – – – –

    We suggest going through the installation instructions once more to ensure all the settings are set: installation instructions

    1) Ensure you have the correct v2 API keys
    2) Ensure that the v2 API keys are set in the Contact Form 7 reCaptcha box
    3) Ensure that Version 2 is selected in the plugin settings select box

    If you’ve tried the above and continue to run into the same issue we suggest switching to a default theme such as Twenty Nineteen to ensure the issue is not theme specific. If you’ve switched to a default theme and continue to run into the same issue we then suggest disabling plugins to ensure it’s not a plugin conflict.

    – – – – – – – – – –

    It’s a lot of information but we hope one of the above suggestions solves your issue. We’ll leave this thread open for a few days or until we hear back from you. Should you continue to have issues or have any additional questions please reply below. Have a wonderful rest of your week!

    Thread Starter basvandijkk

    (@basvandijkk)

    @iqcomputing

    – I have selected the V2 version as stated in my original question. https://ibb.co/RczFfRM

    – I’m running version 1.1.9.

    – Ran through installation instructions again(did not help).

    – Changed active theme to Twenty Seventeen, recaptcha now works so I guess it’s theme specific.

    I will look into this myself. Thanks for all your support

    Hi there,

    I have the same problem, how did you resolve it @basvandijkk ?

    Thanks a lot!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Still loading V3.’ is closed to new replies.