WordPress.org

Forums

SoundCloud Shortcode
Still having troubles with secure embeds (2 posts)

  1. idleberg
    Member
    Posted 1 year ago #

    I was glad to see the new SSL behaviour in 3.0.2 introduced, but I still don't get to see embeds displayed when browsing securely. From a look at the source, I can see the iframe is using a secure link, but the player does not display. Everything works as desired when browsing non-securely, even though the iframe code is the same.

    Edit:

    When I take a look at the page source, the iframe is loaded using https

    <iframe width="100%" height="166" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player?url=https%3A%2F%2Fapi.soundcloud.com%2Ftracks%2F121955716&auto_play=false&show_comments=false&color=362f2d&visual=true&show_artwork=false">

    However, Chrome inspector will still report this error:

    [blocked] The page was loaded over HTTPS, but ran insecure content from 'http://w.soundcloud.com/player/?url=https%3A%2F%2Fapi.soundcloud.com%2Ftrac…play=false&show_comments=false&color=362f2d&visual=true&show_artwork=false': this content should also be loaded over HTTPS.

  2. idleberg
    Member
    Posted 1 year ago #

    I have just noticed that Chromium's inspector displays the player correctly, though the inspector outputs the same warning as above

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SoundCloud Shortcode
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.