Support » Plugin: Popups for Divi » Still having issues with 3.03

  • I’ve disabled it for now, but it hangs the site when any pages with the plug-in are used.

    Can I check if it is just me, or if anyone else is having the problem?

    Great plugin by the way, and appreciate all the hard work!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hey! I’m having the exact same issue on 3 different sites running this plguin — I wrote a bit more about my findings in this thread: https://wordpress.org/support/topic/seemingly-big-issue-with-latest-release/

    The dev has been super helpful but hasn’t seen this happen on any of his tests. My best guess at this point is that there’s a conflict with another plugin or with hosting..? Any chance you’re hosting on Lightsail?

    Here’s my plugins I’m running on a sample site with this issue — any of these in use on your site?

    • Advanced Custom Fields PRO
    • BackWPup
    • Classic Editor
    • Companion Auto Update
    • Disable Comments
    • Disable XML-RPC
    • Divi Carousel
    • EWWW Image Optimizer
    • Gravity Forms
    • Simple Custom Post Order
    • Surbma | Divi & Gravity Forms
    • The SEO Framework
    • Wordfence Security
    • WP Add Mime Types
    • WP Mail SMTP
    • WP Rollback
    • WP Super Cache

    Exact same issue here since update.

    @dancappdesign – is the site in question on Lightsail by chance? And are you running any of the plugins listed above?

    Just trying to get to the bottom of this. It’s having a pretty big impact on a few clients sites for us.

    Hi Grex. No, this is on LiquidWeb. And yes, I have Classic Editor installed.

    I’ve just rolled back to Popups for Divi 2.3.6 to get my site working again. Will perhaps try the next version when it’s released.

    Thread Starter shilldiy

    (@shilldiy)

    Interesting… FYI plugins we share are;

    Classic Editor
    EWWW Image Optimizer
    Gravity Forms
    WP Mail SMTP

    Plug-in currently disabled. May look to roll back to 2.3.6 if no update to 3.0.4 planned in the very near future…

    Looking forward to an update! This is breaking my sites, and I have to disable the plugin or rollback to earlier versions. I hope it can be fixed soon!

    Yeah, I’m in the same boat — Going to have to manually revert back to 2.3.6 — Clients are starting to get grumpy with no popups on their site..

    I’ve tried disabling all plugins and running only Popups for Divi, but sadly am still having the Javascript hang behavior. Very odd.

    I had a hunch it may have been linked to JQuery Migrate, but removing that from WordPress didn’t remedy the issue..

    • This reply was modified 2 months, 2 weeks ago by grex22.

    Well.. wouldn’t you know.. Updating to the latest version of WordPress solved the underlying hanging issue. I spotted that a jQuery function was running repeatedly, and thought it may be tied to the older version of jQuery loading before WP 5.5.

    That seems to be the case, as updating for me on at least one site prevented the hang. I’ve yet to try on the 2nd and 3rd site, but will post back if I have updates.

    For the rest of the folks on this thread, you may check if you’re running WP version < 5.5

    For the plugin author — you probably need to update your WP minimum version requirement, if this proves true.

    Hello @grex22,

    Yes, this is true 🙂

    The latest version works only with the updated WordPress version as it updates the Jquery to the latest version too. I would suggest to check the wordpress version and your php version to avoid any of the above mentioned issues.

    Please get back to me, in-case of any query.

    Regards,
    Syed

    Thanks Syed! Currently the plugin page here on WordPress.org states that the plugin requires ” 4.0.0 or higher ”

    I’m not sure what the exact version number required is, but guessing at least 5.5 at minimum?

    Updating that info might at least safe a few more support threads on the matter 🙂

    Love the plugin! Thanks for the work on maintaining this!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.