Support » Plugin: Dropbox Photo Sideloader » still having an issue with spaces in file

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Samuel Wood (Otto)

    (@otto42)

    Unfortunately, there is no good fix for this at this time, because the underlying problem is in WordPress itself:

    https://core.trac.wordpress.org/ticket/16330

    If this gets fixed in WordPress, then I will be able to correctly patch the plugin. Until that fix happens, any fix I make now will be slightly broken for some use case.

    Thanks for responding
    Someone responded here http://wordpress.org/support/topic/error-when-sideloading
    About altering a line if code
    Do you know how can you explain where to do this – any help is appreciated thanks

    I ran into this problem as well, and for me it was a problem with having spaces in the URL I was trying to get (it looks like you probably have the same problem).
    There is an open ticket about this:
    https://core.trac.wordpress.org/ticket/16330

    As a desperate quick fix, I wound up changing my wp-admin/includes/file.php to change spaces into “%20″s — though changing core files is a really bad idea! (I needed a solution Right Now, and I will be keeping track of the changes, as well as the ticket to see if it gets resolved.)

    Thanks for the nice plugin!

    I just tried to sideload images with spaces but that doe not work. An image without spaces was side loaded without problem. Since there was no visible user feedback I side loaded it several times;)

    The WP core issue was closed (see https://core.trac.wordpress.org/ticket/16330#comment:48). Maybe Dropbox Photo Sideloader could be updated now?

    bye,
    Karsten

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    Updated.

    Also, there is visible user feedback, the screen reloads and the very first lines on the new screen tell you each image that gets sideloaded and whether it is a success or a failure.

    Wow! Works now really smooth now;)

    And you are right. There is visible user feedback. The sideload took longer as expected so I missed a spinning wheel or something to keep me entertained;)

    Thanks again.

    bye,
    Karsten

    seems good i m gonna try it and will post after it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘still having an issue with spaces in file’ is closed to new replies.