Support » Plugin: WooCommerce » Still having an issue with product gallery in 3.0, 3.0.1

  • dubok

    (@dubok)


    I added these lines to functions.php
    add_theme_support( ‘wc-product-gallery-zoom’ );
    add_theme_support( ‘wc-product-gallery-lightbox’ );
    add_theme_support( ‘wc-product-gallery-slider’ );
    But nothing helped…
    There are full size images instead of thumbnails

    When I deleted product_images.php from child theme there is no image at all!

    Anybody please help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • createandcode

    (@createandcode)

    In order to help you, it’s best to let us know what theme you are using?

    Also, check your system status https://docs.woocommerce.com/document/understanding-the-woocommerce-system-status-report/

    If your parent theme is overriding templates like product-image.php then simply adding support for the new gallery won’t be enough. Your theme author should test and add support for WooCommerce 3.0

    Plugin Author Mike Jolley

    (@mikejolley)

    If it’s a WC compatible theme, ask the author to update it.

    shuiiz

    (@shuiiz)

    I use mystile theme (a wordpress theme) and I have the same problem. I have already upgrade woocommerce and mystile to the most recent version. Can you help me please?

    Thread Starter dubok

    (@dubok)

    Thanks for the reply.
    What if theme author do not provide updates for a long time? What should I do the theme would be compatible with 3.0? Could you give instructions please.
    Thanks.

    Plugin Author Mike Jolley

    (@mikejolley)

    mystile will be updated soon – they are adding gallery support.

    Thread Starter dubok

    (@dubok)

    Could you reply to my topic?
    What if theme author do not provide updates for a long time? What should I do the theme would be compatible with 3.0? Could you give instructions please.
    Thanks.

    I’m also currently experiencing issues with my gallery images. I have just updated to Woocommerce 3.0.4. (with backing up, but stupidly without testing) and am using the latest Mystile theme.

    Currently, images fail to show on individual product pages, even though by the text that is being pushed all the way down, it seems like they are full-sized.

    Is there a problem on my end or is this a bug that will be fixed in time? I would hate to adjust another theme completely to my liking!

    Here’s a page as an example:
    https://www.1000crows.com/product/las-vegas-glass-beer-stein/

    Many thanks,

    Yvette

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Still having an issue with product gallery in 3.0, 3.0.1’ is closed to new replies.