Support » Fixing WordPress » Still getting Pingbacks even though I disabled them in settings?

  • Resolved ameliamadelaine

    (@ameliamadelaine)


    Hi,
    I’ve just started getting a few pingbacks appear in my comments section even though I disabled them from the main settings.
    Anyone have any ides why this would be happening?
    I only moved my blog to wordpress about a month ago and have just had a few begin to appear this last week.
    Thanks so much for any help,
    Amelia

Viewing 2 replies - 1 through 2 (of 2 total)
  • Disabling pingbacks in your settings will only affect posts and pages you create after changing this setting, NOT any existing ones!

    You can manually go in and change each one or you could try adding this to your themes function file…

    // Disable Comments in Old Posts
    add_filter( 'the_posts', 'royal_close_comments' ); 
    
    function royal_close_comments( $posts ) {
    	$posts[0]->ping_status    = 'closed';
    	return $posts;
    }

    Oh great! Thank you so much for that!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Still getting Pingbacks even though I disabled them in settings?’ is closed to new replies.