Support » Plugin: Contact Form 7 Image Captcha » Still does not work with version 5.4 of Contactform

  • Resolved domdomdomdom

    (@domdomdomdom)


    hello,

    Still does not work with version 5.4 of Contactform.

    Even with your update 7.5 today, we have the hourglass when sending the form (especially on mobile);

    I had to go back to ContactForm version 5.3.2 to make it work as before.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Kyle Charlton

    (@ktc_88)

    Hello,
    It appears this is concerning the pro version of the plugin.

    The problem is with Contact Form 7, their last update was a major update which broke on a lot of sites, especially those using speed optimization plugins. The update I made to the All-In-One Image CAPTCHA plugin was to fix the plugin to work with CF7.

    Your problem is most likely the CF7 plugin. If you are using a speed optimization plugin, and are using the most recent version of CF7, you need to tweak the settings of your speed optimization plugin so as not to break CF7.

    I use WP Rocket and I had to turn off the options to Combine JavaScript files, Load JavaScript deferred, and Delay JavaScript Execution

    CF7 made the decision to drop jQuery which is a good thing, however the way they did it is causing a lot of JavaScript errors which is what the All-In-One Image CAPTCHA and a lot of other plugins rely on. If there is a JavaScript error on your site, you can expect there to be things that might not work.

    Thread Starter domdomdomdom

    (@domdomdomdom)

    For speed optimization I use the “Autoptimize” plugin like many others.
    Of course I have already tried all the possible settings and exceptions to get it to work properly with your pro version and the latest version of ContactForm 7.
    But it doesn’t work, because either the site is too slow or it breaks my site.

    So if the problem is with your pro version, how do you go back to your normal, free version of your plugin?

    Or which otion to deactivate on your pro version so that it works with “Autoptimize”?

    ————

    I just tried your free version on my other site (https://www.alcor-environnement.fr/demande-diagnostics-immobiliers-divers/), we have another problem:
    We cannot select the image of the capcha when we click on it in mobile version (Iphone).

    And when I update ContactForm, even with another capcha I also have the hourglass running …

    —————-

    And on this site too, which nevertheless uses WP Rocket, latest version of ContactForm, on mobile Iphone impossible to select the image of your Captcha (free version): https://www.diagnostic-pollution-des-sols.pro

    • This reply was modified 1 year, 8 months ago by domdomdomdom.
    • This reply was modified 1 year, 8 months ago by domdomdomdom.
    • This reply was modified 1 year, 8 months ago by domdomdomdom.
    Plugin Author Kyle Charlton

    (@ktc_88)

    The problem is with Contact Form 7 not the Pro plugin in regards to it not working. Contact Form 7 is breaking the JavaScript.
    To use the free version, simply deactivate the pro version and install and activate the free version (they are two separate plugins).

    I am aware of the iPhone issue and plan on fixing it.

    Thread Starter domdomdomdom

    (@domdomdomdom)

    If I understand correctly, we have to change cache plugins, ie replace Autoptimize for WProcket.

    Do you know when will have solved the iPhone problem?

    Plugin Author Kyle Charlton

    (@ktc_88)

    I just updated the free version to 3.2.2 which has a suggested iPhone fix, please update the free version and see if that resolves the iPhone bug, you might need to clear your iPhone browser cache first.

    I have never used Autoptimize so I don’t know much about it, but it should work so long as you have the JavaScript settings correctly set to work with Contact Form 7.

    I just looked at your site and I see that you do have some JavaScript errors, one of which is for Google reCAPTCHA, I would advise turning off Google reCAPTCHA if you are using Contact Form 7 Image CAPTCHA as I have had some reports the Google reCAPTCHA causes conflict issues with the Image CAPTCHA. Google reCAPTCHA also slows websites down by 1.5 seconds in some cases, which is a lot.

    Hello Kyle. My issue is a bit different. It all works perfectly but the icon (Image) for changing the captcha characters, doesn’t show. Its a small image (gif?) but I can’t seem to find a solution, or a setting to change that particular part of the captcha. Is there a way to increase or decrease the size of that little image? I use CF7 and Elementor Pro.
    Thanks
    Adolfo

    Solved, thank you.

    Thread Starter domdomdomdom

    (@domdomdomdom)

    Do you know when will have solved the iPhone problem for pro version (Safari Iphone)?

    • This reply was modified 1 year, 8 months ago by domdomdomdom.
    Plugin Author Kyle Charlton

    (@ktc_88)

    I am currently doing research into this issue, unfortunately, I do not own an iPhone which makes testing difficult (and iPhone does things differently than all the other web services which makes debugging even more difficult).
    Finding a solution for the iPhone bug is at the top of my list.

    Thread Starter domdomdomdom

    (@domdomdomdom)

    not a priority? Today mobile browsing represents nearly 50% of visits and iPhone browsing nearly 50% as well. Either one in 4 requests cannot be sent with your Capcha, which makes it unusable

    Plugin Author Kyle Charlton

    (@ktc_88)

    It is a priority, the top of my list, meaning spot number 1 🙂

    Plugin Author Kyle Charlton

    (@ktc_88)

    Just a quick update concerning the double tap iPhone issue, I purchased a refurbished iPhone which arrived the other day and I have been working on the issue since it arrived.
    Unfortunately none of the changes I’ve tried have fixed the issue which is very strange since its working for the free version.
    I am continuing my investigation into this issue and will update you when a solution has been found.

    Plugin Author Kyle Charlton

    (@ktc_88)

    Update: It looks like this issue is cache related. I found that the double tap issue was not a problem on sites not using speed optimization plugins. I use WP Rocket on my website and I found that if I turned off the option to Delay JavaScript execution the double tap issue went away.

    Plugin Author Kyle Charlton

    (@ktc_88)

    Marking as resolved since the double-tap issue is an issue with WP Rocket and not the plugin itself. WP Rocket currently has a ticket open concerning the double-tap issue and they have been actively working on a solution with different attempts through several of their recent updates.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Still does not work with version 5.4 of Contactform’ is closed to new replies.