Support » Plugin: 404page - your smart custom 404 error page » Still displaying the theme’s 404 page with Polylang

  • Resolved thomasbachem

    (@thomasbachem)


    Hi Peter,

    I’ve Polylang Pro enabled, so the compatibility mode gets chosen automatically. It doesn’t work however, I still see the theme’s native 404.php template (nothing fancy, custom theme based on twentysixteen).

    The reason: $posts is never empty, it always contains the two blog posts I have on the site. That seems very strange to me, but debugging it in class-wp-query.php turned out to be really complex.

    Manually switching to STD mode does make it work however.

    I propose we either find out why my installation still fills up $posts even when 404ing, or you still let the user switch between STD/CMP mode manually, even if Polylang was detected.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Peter Raschendorfer

    (@petersplugins)

    Hi Thomas,

    thanks a lot for your detailed description. Sounds strange. Have you tried to disable all other plugins?

    Liebe Grüße aus Salzburg
    Peter

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Hi Thomas,

    I found a different solution to load the translated page with Polylang. This solution now also works in Standard Mode for a lot of Themes I’ve tested it with. So it’s no longer necessary to automatically switch to Compatibility Mode if Polylang is detected.

    Would you please download and install the current development version from https://downloads.wordpress.org/plugin/404page.zip and test it. In this version you should be able to switch to Standard Mode. Please let me know.

    Regards,
    Peter

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Final version 2.4 is out now. Please confirm the issue is solved and the topic can be closed.

    Peter

    Hi Peter,

    thanks a lot, works now!

    Best
    Tom

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.